Quicktime 7.0.3 Plug-in Crashes Firefox [@ QuickTimeH264.qtx + 0x9be9e (0x67f1be9e) 0d648310]

RESOLVED INVALID

Status

Plugins Graveyard
QuickTime (Apple)
--
critical
RESOLVED INVALID
13 years ago
2 years ago

People

(Reporter: Eric Portelance, Unassigned)

Tracking

({crash, top100, topcrash+})

Details

(crash signature, URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051012 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051012 Firefox/1.4.1

After installing the new iTunes 6 (which comes with Quicktime 7.0.3), Firefox
now crashes when trying to view a Quicktime movie.

Reproducible: Always

Steps to Reproduce:
1.  Install new iTunes (which comes with Quicktime 7.0.3)
2.  Go to http://www.apple.com/ipod/ads
3.

Actual Results:  
Error message:
"QuickTime Plug-in 7.0.3  The plug-in performend an illegal operation.  You are
strongly advised to restart Firefox."

Firefox then crashes shortly thereafter.

Expected Results:  
The video should have kept playing.

Talkback crash ID:  TB10567883K
(Reporter)

Comment 1

13 years ago
Requesting blocking 1.8rc1
Flags: blocking1.8rc1?

Comment 2

13 years ago
Wouldn't this be a QT problem, not a FF problem?
Summary: Quicktime 7.0.3 Plug-in Crashes Firefox → Quicktime 7.0.3 Plug-in Crashes Firefox [Crash@ QuickTimeH264.qtx + 0x9be9e (0x67f1be9e) 0d648310]

Comment 3

13 years ago
BTW, this looks fine for me using QT 7.0.2, 1.5beta2
(Reporter)

Comment 4

13 years ago
I also thought that it could be a QT problem, but I periodically get C++ runtime
errors in firefox.exe after the plugin screws up.  I also got a memory read
error, which I'm trying to duplicate so that I can write the info down.  It was
also working fine for me in 7.0.2.  This is something that should be looked into
either way.

Comment 5

13 years ago
WFM - QT 7.0.3 on MacOS-X Tiger 10.4.2 and a one day old homemade trunk build.

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051011
Firefox/1.6a1

Windows only, so ?

(Reporter)

Comment 6

13 years ago
Here is the error I occasionally get when I experience this crash:

"The instruction at "0x67f1be9e" referenced memory at "0x0000000d".  The memory
could not be "read"."

Comment 7

13 years ago
I experienced a similar crash, but did not get the "plug-in performed an illegal
operation" message.  Quicktime 7.0.3, Firefox 1.5 beta 2, Windows XP.  Talkback
ID: TB10569227G
stack comment 0

Incident ID: 10567883
Stack Signature	QuickTimeH264.qtx + 0x9be9e (0x67f1be9e) 0d648310
Product ID	Firefox15
Build ID	2005101205
Trigger Time	2005-10-12 12:17:39.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	QuickTimeH264.qtx + (0009be9e)
URL visited	
User Comments	Trying to watch a Quicktime movie (Quicktime 7.0.3 which came with
iTunes 6)
Since Last Crash	6145 sec
Total Uptime	6145 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
QuickTimeH264.qtx + 0x9be9e (0x67f1be9e)
QuickTimeH264.qtx + 0x25094 (0x67ea5094)

Comment 9

13 years ago
Rafael, who do we know with Quicktime that can look into this crasher?

Comment 10

13 years ago
*** Bug 312290 has been marked as a duplicate of this bug. ***

Updated

13 years ago
Keywords: top100, topcrash
Summary: Quicktime 7.0.3 Plug-in Crashes Firefox [Crash@ QuickTimeH264.qtx + 0x9be9e (0x67f1be9e) 0d648310] → Quicktime 7.0.3 Plug-in Crashes Firefox [@ QuickTimeH264.qtx + 0x9be9e (0x67f1be9e) 0d648310]

Comment 11

13 years ago
This WFM using 1.5b2 on win2000 with quicktime 7.0.3.25 (latest currently
available, but I used standalone rather than itunes install)
Keywords: crash

Updated

13 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 1.5 Branch

Comment 12

13 years ago
(In reply to comment #11)
> This WFM using 1.5b2 on win2000 with quicktime 7.0.3.25 (latest currently
> available, but I used standalone rather than itunes install)

Same here - 1.5b 20051013, QT 7.0.3.25 standalone WFM.
I doesn't have the correct quicktyme plugin, result: no crash :p

Comment 14

13 years ago
I crash every time I visit that link, I first get a messag saying that the
plugin did an illegal operation something, after that Firefox dies

Tested the following build with a fresh profile:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051013
Firefox/1.4.1

I have QuickTime Plug-in 7.0.2, so the summary is not correct

Comment 15

13 years ago
TB10618360G

Comment 16

13 years ago
BTW: the other crasher URL from dupe 312290 is 
http://www.apple.com/de/ipod/features.html

Comment 17

13 years ago
*** Bug 312383 has been marked as a duplicate of this bug. ***

Comment 18

13 years ago
This crash makes up about 15% of all crashes for Firefox 1.0.7
(http://talkback-public.mozilla.org/reports/firefox/FF107/FF107-topcrashers.html),
marking topcrash+ and nominating for 1.0.8.  According the the latest Talkback
data, this crash popped up in the past few days... most likely due to new
content or changes to the Apple website.  Looking at the comments in this report:
http://talkback-public.mozilla.org/reports/firefox/FF107/simple-crash-analysis.all

It looks like http://www.apple.com/ipod/features.html attracted a lot of hits
recently due to the Apple news... so this could be a spike for an existing
crash. But, if that many users are seeing this, we need to figure out if there
is anything we can do to prevent it in the future.  Could be Apple being bad or
something in our code.  Adding helpwanted and cc'ing jst in case he knows anyone
that can look into this.
Flags: blocking-aviary1.0.8?
Keywords: topcrash → helpwanted, topcrash+
Jesse, I think you meant to cc some actual mac folks instead of me and biesi,
right?  This crash is in the plugin itself...

Comment 20

13 years ago
This url crashes any browser (IE 6 and Opera etc)
(Reporter)

Comment 21

13 years ago
Does not crash IE6 for me.  Haven't tried Opera.

Comment 22

13 years ago
the description is not correct. firefox crashes when trying to view a h264 encoded quicktime movie.
and not every h264 movie. for example http://www.continentseven.com/movec7.php?moveid=450 
crashes and http://www.continentseven.de/video72.php?moveid=97 isn't crashing. these two clips only 
differ in bitrate, duration and audio, but are both h264 encoded.
that bug is also not always reproducable. i've also seen it working on some systems and crashing on 
other systems. see also: http://forums.whirlpool.net.au/forum-replies.cfm?t=398876&p=1
i 've also experienced that on one windows 2000 pc with firefox 1.5 beta 2 http://
www.continentseven.com/movec7.php?moveid=450 crashes, but won't crash if i open that page in a 
background tab. after changing the tab i could watch the short clip without a problem.

Comment 23

13 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051013
Firefox/1.4.1

Using latest version of standalone QT plugin(7.0.3.25).  No crash with original
example:

http://www.apple.com/ipod/ads/

But I do crash at the URL in comment #22:

http://www.continentseven.com/movec7.php?moveid=450 

TB10665483K

Comment 24

13 years ago
We believe that this is a QuickTime plugin problem and not a Firefox problem. It
also appears that this has been fixed in the latest QuickTime release so we're
nog going to block our release on this problem. If anyone can demonstrate that
this is a Firefox bug, please re-nominate with an explanation. Thanks.
Flags: blocking1.8rc1? → blocking1.8rc1-
(Reporter)

Comment 25

13 years ago
(In reply to comment #24)
> We believe that this is a QuickTime plugin problem and not a Firefox problem. It
> also appears that this has been fixed in the latest QuickTime release so we're
> nog going to block our release on this problem. If anyone can demonstrate that
> this is a Firefox bug, please re-nominate with an explanation. Thanks.

I have no reason to believe that it *would* be a Firefox bug, but then again I
really don't know.  What I do know, however, is that it has not been fixed in
the latest Quicktime release because this is precisely the version that I am
experiencing the bug with (7.0.3).

Comment #14 also states that it crashes on 7.0.2, but I personally did not
experience this before I upgraded.

Comment 26

13 years ago
I'm running Quicktime 7.0.3.25 and I get a crash with the latest Firefox nightly
almost immediately at http://www.apple.com/ipod/ads/ so I have to concur with
Eric that the problem is not resolved.

The same site crashed with IE6 and QT 7.0.2 but I don't get an IE crash with 7.0.3.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051017
Firefox/1.4.1

Updated

13 years ago
Assignee: nobody → joshmoz

Comment 27

13 years ago
I don't know why this bug is assigned to me - I don't have a Windows box and
have never really done much of anything on Windows, so I'm afraid I can't help
you here.

Comment 28

13 years ago
bz: this crash happens on Windows, not Mac.

Asa: I'm renominating because this bug is reported as happening with the latest
version of QuickTime.
Flags: blocking1.8rc1- → blocking1.8rc1?

Updated

13 years ago
Assignee: joshmoz → nobody
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: 1.5 Branch → 1.8 Branch

Comment 29

13 years ago
Johnny, do you thikn there's anything we can do on our end to prevent this from
crashing?

Comment 30

13 years ago
Stupid question: did anyone file a bug with Apple (http://bugreporter.apple.com).

Comment 31

13 years ago
Yes, this issue has been reported to Apple.

Comment 32

13 years ago
(In reply to <a href="#c29">comment #29</a>)
&gt; Johnny, do you think there's anything we can do on our end to prevent this 
&gt; from crashing?

This is a QuickTime bug, it is not possible to work around it in Firefox.

Updated

13 years ago
Flags: blocking1.8rc1?
Flags: blocking-aviary1.0.8?

Comment 33

13 years ago
Marking invalid per comment 32 (not a bug in Firefox).
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: helpwanted
Resolution: --- → INVALID
*** Bug 315640 has been marked as a duplicate of this bug. ***
*** Bug 315706 has been marked as a duplicate of this bug. ***

Comment 36

13 years ago
*** Bug 312250 has been marked as a duplicate of this bug. ***

Comment 37

13 years ago
*** Bug 316650 has been marked as a duplicate of this bug. ***

Comment 38

13 years ago
*** Bug 316650 has been marked as a duplicate of this bug. ***

Comment 39

13 years ago
*** Bug 318165 has been marked as a duplicate of this bug. ***

Comment 40

13 years ago
Just an update: the crashes still occur with QuickTime 7.0.3.50

Comment 41

13 years ago
FYI, this appears to be fixed with Quicktime 7.0.4.
My qt plugin reads version 7.0.4.80 and I have no more crashes with the links above.
(Reporter)

Comment 42

13 years ago
Yes, as was stated previously, this was a Quicktime bug that actually affected every browser (on my system at least) in different ways (causing crashes and such).  The H264 bug is fixed in the latest release of Quicktime.

Comment 43

12 years ago
*** Bug 334159 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 366488

Updated

8 years ago
Component: Plug-ins → QuickTime (Apple)
Product: Core → Plugins
QA Contact: plugins → apple-quicktime
Version: 1.8 Branch → unspecified
(Assignee)

Updated

7 years ago
Crash Signature: [@ QuickTimeH264.qtx + 0x9be9e (0x67f1be9e) 0d648310]
(Assignee)

Updated

2 years ago
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.