Don't perform DNS lookup before "I'm feeling lucky" google search when the text in the location bar is clearly not a URL

RESOLVED DUPLICATE of bug 245597

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 245597
12 years ago
12 years ago

People

(Reporter: Kartik Agaram, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

When I type some text into the location bar it seems to first check it for
bookmark keyboard shortcuts, then tries to resolve it with the DNS server, then
finally performs a google "I'm feeling lucky" search.

If the text is clearly not a URL, however, it should be possible to eliminate
the DNS lookup, which can have significant latency depending on your provider.
As a result of this extra latency I end up duplicating frequently used keyboard
shortcuts even though just looking up google would work.

Some possible heuristics that the text in the location bar is not a URL:
a) it has no periods
b) spaces before periods

Reproducible: Always

Steps to Reproduce:
1.Type bbc into the location bar
Actual Results:  
1.Stare at the "Looking up bbc.." message in the status bar for a while.
2.Watch it go to google and instantly find http://www.bbc.co.uk. This step
happens very fast.

Expected Results:  
Instantly access google and find http://www.bbc.co.uk
(Reporter)

Updated

12 years ago
Summary: automatically perform "I'm feeling lucky" google search when the text in the location bar is clearly not a URL → don't perform dns lookup before "I'm feeling lucky" google search when the text in the location bar is clearly not a URL
This may be the same as bug 245597. However the example that you quote (bbc)
does require a dns lookup. There may be a computer on a users network, or in the
default search domain with the name bbc in which case the website on that
machine should be viewed.
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> This may be the same as bug 245597.

Agh sorry, I should have done a better search for duplicates. Address vs
location bar again.

> However the example that you quote (bbc) does require a dns lookup. There may be 
> a computer on a users network, or in the default search domain with the name bbc 
> in which case the website on that machine should be viewed.

I hadn't thought of this. I don't have an objection to marking this as a dup.

A possible heuristic: only skip the DNS lookup if there's no default domain
suffix, or if the DNS server is a class A IP address.
  http://searchwebservices.techtarget.com/sDefinition/0,,sid26_gci212381,00.html
(Reporter)

Updated

12 years ago
Summary: don't perform dns lookup before "I'm feeling lucky" google search when the text in the location bar is clearly not a URL → Don't perform DNS lookup before "I'm feeling lucky" google search when the text in the location bar is clearly not a URL

*** This bug has been marked as a duplicate of 245597 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.