mail servers can't be resolved after long session

RESOLVED DUPLICATE of bug 312316

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 312316
13 years ago
13 years ago

People

(Reporter: junkaddr, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

When I leave Thunderbird open for a long time (what seems to be longer than one
day), it can no longer contact my mail servers.  It never manages to connect to
hosts instead just sitting at "Connecting to mail.host.com...".  This happens
for both POP3 and SMTP servers.  Closing and restarting Thunderbird always
resolves the problem immediately.

Reproducible: Always

Steps to Reproduce:
1. Leave Thunderbird open for a long time (>24h?)
2. Check or send mail
3.

Actual Results:  
Thunderbird fails to connect to POP3 or SMTP servers.

Expected Results:  
Connected immediately.

Comment 1

13 years ago
Can you access the hosts via normal methods?  I.e. ping host.com?
(Reporter)

Comment 2

13 years ago
I'll have to wait for it to happen again, but yes, I believe the hosts are
otherwise accessible.

I was leaving my session open today to reproduce again, and something strange
just happened.  I let the "Connecting to" time out completely, it brought up a
dialog saying that it failed to connect, and the next attempt work fine.  I'll
try this again when I reproduce next.

Perhaps some kind of bad DNS caching?

Comment 3

13 years ago
I wouldn't think it was a DNS issue, but lets see if you can access the host via
other methods when Thunderbird is saying its inaccessible to cut out
hardware/network issues first.

When the reporter restarts Thunderbird, it can access the mail server. I think that rules out network 
problems, right?
I'm pretty certain this is a dupicate of bug 312316, which contains an SMTP log.

*** This bug has been marked as a duplicate of 312316 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 6

13 years ago
Most certainly a duplicate.

Thanks for picking this up! :)
You need to log in before you can comment on or make changes to this bug.