Firefox ignores localhost and/or 127.0.0.1 on "no proxy for" list

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
13 years ago
11 years ago

People

(Reporter: xs, Unassigned)

Tracking

Trunk
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

My no-proxy-for list is:
"*dell.*;*.dell.*;163.244.*;10.*;143.266.*;localhost;127.0.0.1"

However, Firefox navigates to localhost through proxy! IE doesn't do that and
displays my local webserver homepage correctly.

Reproducible: Always

Steps to Reproduce:



Expected Results:  
Request should not go through proxy with requested host on "no proxy for" list.
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5 Branch
Assignee: nobody → darin
Component: Preferences → Networking
Product: Firefox → Core
QA Contact: preferences → benc
Version: 1.5 Branch → 1.8 Branch

Comment 1

13 years ago
The exclusion list doens't use the IE's star syntax.
(there's a comment below that explains how to use it !)

*** This bug has been marked as a duplicate of 260883 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Comment 2

13 years ago
V/dupe.

Firefox should have ignored localhost w/ the original settings. You should try a
new profile and see.

To get your config working, see if:

http://www.mozilla.org/quality/networking/docs/aboutno_proxy_for.html

helps. It might be out of date, so let me know.
Status: RESOLVED → VERIFIED

Comment 3

13 years ago
REOPEN:
actually thinking this isn't the same syntactical problem as 260883, so
reopening, until reporter's config is working, then I'll dupe.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

12 years ago
Assignee: darin → nobody
QA Contact: benc → networking
Version: 1.8 Branch → Trunk
no response
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago11 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.