If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Edit keyboard shortcuts don't work in dialogs

RESOLVED FIXED

Status

()

Core
XUL
P3
major
RESOLVED FIXED
18 years ago
9 years ago

People

(Reporter: Eli Goldberg, Assigned: saari (gone))

Tracking

({regression, relnote})

Trunk
regression, relnote
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

(Reporter)

Description

18 years ago
* To reproduce:
1: From the Search menu, select "Find on this Pageā€¦"
2: Type some text into the "Find Text" field
3: Select the text
4: Type "[Command || Alt || Control] -X", as appropriate for your platform.

* Actual results:
The text isn't cut. Similarly, text copied isn't copied, and text pasted isn't 
pasted.

* Expected results:
Should behave similar to URL bar; keyboard shortcuts to edit menu commands (cut, 
copy, paste, select all) should work.

* Builds checked:
2000030814 & 2000030909 Mac OS
2000030909 Win32
2000030909 Linux (note that Cut/Copy works, but Paste & Select All don't.)
(Reporter)

Comment 1

18 years ago
Raising severity to 'major', cc'ing saari. 

Adding beta1 keyword even though I accept that it won't happen for beta 1. ;)
Severity: normal → major
Keywords: beta1
wicked. "open web location" does work, but find (which is not a modal dialog, 
btw) does not. saari?
Assignee: pinkerton → saari
my $0.02: i'm able to paste (Command+V), on Mac, using 2000.03.09.13 [non-comm.
opt] to:

* a textfield in the Preferences dialog (Navigator panel, Home Page field)
* the Location field (Navigation Toolbar)
oh, duh, ignore my remark about the Location field above...

anyhow, perhaps this is limited to the Find on Page dialog? (since it doesn't
occur in Preferences or Open Web Location...) claudius/grace, d'you see this in
the dialogs you work on?

Comment 5

18 years ago
Putting on PDT- radar for beta1.  Will Relnote.

Keywords: relnote
Whiteboard: [PDT-]

Comment 6

18 years ago
tried this in profile wizard today- ctrl/x does not delete profile name nor can 
I paste data in profile name with ctrl/v
Keywords: regression
Summary: [Regression] Edit Keyboard shortcuts don't work in dialogs → Edit keyboard shortcuts don't work in dialogs
(Assignee)

Comment 7

18 years ago
Looks like this is pretty limited in scope.
Status: NEW → ASSIGNED
Target Milestone: M16

Updated

18 years ago
Target Milestone: M16 → M17

Comment 8

18 years ago
Mass-moving all M16 non-feature bugs to M17, which we still consider to be 
part of beta2

Comment 9

18 years ago
need clarification on what modifier key(s) should work.  putting on nsbeta2 
radar
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Keywords: beta1 → nsbeta2
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Resolution: --- → FIXED
Whiteboard: [PDT-]

Comment 10

18 years ago
whoops, reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 11

18 years ago
*** Bug 31254 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
These should all work:
* Undo       (mod+Z)
* Redo       (mod+Y)
* Cut        (mod+X)
* Copy       (mod+C)
* Paste      (mod+B)
* Select All (mod+A)
* Close      (mod+W)
* Quit       (mod+Q)
* Help       (F1 and mod+"?", on all platforms)

That's all I can think of.

Comment 13

18 years ago
On Unix, there are a few more which come from the platform xbl file and should
also be tested to make sure it's also being loaded (if one works, they probably
all will):
^X, ^C, ^V: cut/copy/paste (on control as well as alt)
^U: delete line
^K: delete to end of line
^H: delete back one character
^A: beginning of line
^E: end of line
^W: delete back one word

On Mac, you might want to check to make sure the home/end behaviors are correct
(Kathy?)

Comment 14

18 years ago
[nsbeta2+] 6/1
Whiteboard: [nsbeta2+] 6/1

Updated

18 years ago
Blocks: 40158

Comment 15

18 years ago
Mass moving all dated nsbeta2+ bugs to M19
Target Milestone: M17 → M19
*spam*: transferring current XP Menu bugs over to jrgm, the new component owner.
feel free to add me to the cc list (unless am the Reporter) of any of these, if
you have any questions/etc.
QA Contact: sairuh → jrgm
(Assignee)

Comment 17

18 years ago
works on macos
(Assignee)

Comment 18

18 years ago
works on win2K, despite not being able to see a selection

Comment 19

18 years ago
This all works for linux today for the Ctrl & Shift bindings. I do not get 
any response for Alt-C, Alt-X, Alt-V (for example), but I don't see anywhere
where these are defined. I'll talk to akkana tomorrow to see what it is that
I'm missing (most likely a clue :-\. 
Whiteboard: [nsbeta2+] 6/1 → [nsbeta2+] 6/1 probably fixed, modulo missing bindings

Comment 20

18 years ago
I see a problem on Mac debug build from today.  I am in the image properties 
dialog for Composer.  After I pick a url, I can't select all or use cut if I 
manually make a selection.
(Assignee)

Comment 21

18 years ago
brade, seems to work for me. Must have got introduced recently (my build is from 
Wed. I think)

Comment 22

18 years ago
Updating from [6/1] to [6/15]
Whiteboard: [nsbeta2+] 6/1 probably fixed, modulo missing bindings → [nsbeta2+][6/15] probably fixed, modulo missing bindings
(Assignee)

Comment 23

18 years ago
brade, do you still see this? I don't have a mac right now.

Comment 24

18 years ago
yes, I see this problem still.  Today I tried to select all in the "new bookmark" 
dialogs (Command-A).  Please fix this really annoying bug!!!  :-)  I consider it 
dogfood.
Whiteboard: [nsbeta2+][6/15] probably fixed, modulo missing bindings → [nsbeta2+][6/15]
*** Bug 42455 has been marked as a duplicate of this bug. ***

Comment 26

18 years ago
Cleaning up status whiteboard by marking beta2 minus (6/15 has passed)

Whiteboard: [nsbeta2+][6/15] → [nsbeta2-]

Comment 27

17 years ago
It looks like the initial fix for 42885 fixed this longstanding bug.  Yay!
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 28

17 years ago
sweet!

Comment 29

17 years ago
I can't use Command-A (select all) on a Mac debug build.
Also, is the "redo" shortcut key supposed to work in dialogs? It didn't seem to 
work properly in the Find dialog or image dialog for me.

Updated

9 years ago
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.