browser crashed after entering flash-site

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
13 years ago
11 years ago

People

(Reporter: przemek.zawada, Unassigned)

Tracking

({crash})

1.7 Branch
x86
FreeBSD
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.7.7) Gecko/20050420
Build Identifier: Mozilla/5.0 (X11; U; FreeBSD amd64; en-US; rv:1.7.7) Gecko/20050420

Dear Mozilla.org,

I wonder if my problem which has happen (and is happening lately) with flash
plugins at the web sites is problem of Mozilla - just I'm reporting you anyhow:

1. Platform: AMD Athlon64 2800+
2. OS: FreeBSD 5.4 release - compiled i386, not amd64 distro.
3. Flash plugin: 
   ===>  Deinstalling for www/flashplugin-mozilla
   ===>   Deinstalling flashplugin-mozilla-0.4.12_1

Sample pages I've entered: http://www.intermarche.pl http://slowniki.onet.pl/

Sample console log while running mozilla from cmd-line:
pmz@bsd64$ mozilla
NP_Initialize
New
SetWindow
SetWindow
SetWindow
New
SetWindow
SetWindow
SetWindow
New
SetWindow
SetWindow
SetWindow
NewStream
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
DestroyStream
NewStream
WriteReady
Write
DestroyStream
NewStream
WriteReady
Write
WriteReady
Write
WriteReady
Write
WriteReady
Write
DestroyStream

Destroy
mozilla-bin in free(): error: junk pointer, too high to make sense
Abort trap (core dumped)

End.

I wish I've helped a bit.

Best regards and wishes,
Przemek M. Zawada



Reproducible: Always

Steps to Reproduce:
Written above
Actual Results:  
Written above

Expected Results:  
Written above

Comment 1

11 years ago
I also have the same problem, i'm running Firefox 2.0.0.12 (and older versions too), and when entering some websites wich contain flash, firefox will crash, i know this is a problem with Firefox, because entering those websites with other browsers works fine, i submit my pc info and a log file i made after a crash.

Archlinux 64bits using Gnash
Firefox 2.0.0.12 (older versions had the same problem)
Amd Athlon 64 X2 3.5 Ghz 
2GHz ram

---- log file ---

Error Information:
	An exit code of 139 was returned from firefox .

Output Data:
	There was no output

Error Logs:
	Unsupported movie property id with value "bzfsh"
	Unsupported movie property style with value "position: absolute; top: 1px; left: 1px; height: 1px; width: 1px;"
	Unsupported movie property quality with value "high"
	Unsupported movie property pluginspage with value "http://www.macromedia.com/go/getflashplayer"
	unhandled event 19
	Unsupported movie property id with value "flash_object"
	Unsupported movie property style with value "position: absolute; top: 1px; left: 1px; height: 1px; width: 1px;"
	Unsupported movie property quality with value "high"
	Unsupported movie property pluginspage with value "http://www.macromedia.com/go/getflashplayer"
	Unsupported movie property id with value "mymovie"
	Unsupported movie property name with value "mymovie"
	Unsupported movie property quality with value "best"
	Unsupported movie property menu with value "false"
	Unsupported movie property wmode with value "transparent"
	unhandled event 19
	Unsupported movie property id with value "mymovie"
	Unsupported movie property name with value "mymovie"
	Unsupported movie property quality with value "best"
	Unsupported movie property menu with value "false"
	Unsupported movie property wmode with value "transparent"
	Unsupported movie property id with value "playerSapoFLV"
	Unsupported movie property name with value "playerSapoFLV"
	Unsupported movie property quality with value "high"
	Unsupported movie property allowscriptaccess with value "always"
	Unsupported movie property allowfullscreen with value "true"
	Unsupported movie property id with value "playerSapoFLV"
	Unsupported movie property name with value "playerSapoFLV"
	Unsupported movie property quality with value "high"
	Unsupported movie property allowscriptaccess with value "always"
	Unsupported movie property allowfullscreen with value "true"
	unhandled event 19
	Loading stream: http://imgs.sapo.pt/sapovideo/swf/flvplayer.swf
	SWFDEC: ERROR: swfdec_text_field.c(143): tag_func_define_edit_text: id 281 does not specify a font
	Loading stream: http://rd3.videos.sapo.pt/crossdomain.xml
	Loading stream: http://cache03.stormap.sapo.pt/vidstore02/videos/16/dc/91/318171_UuFpY.flv
	SWFDEC: ERROR: swfdec_net_stream.c(572): swfdec_net_stream_seek: seeking to -1,54235e-180 doesn't work
	Unsupported movie property id with value "bzfsh"
	Unsupported movie property style with value "position: absolute; top: 1px; left: 1px; height: 1px; width: 1px;"
	Unsupported movie property quality with value "high"
	Unsupported movie property pluginspage with value "http://www.macromedia.com/go/getflashplayer"
	unhandled event 19
	Loading stream: about:blank
	/usr/lib/firefox-2.0.0.12/run-mozilla.sh: line 131:  8799 Segmentation fault      "$prog" ${1+"$@"}Error Logs:
	Unsupported movie prop


MozillaAS v1.7.x is not supported anymore.

Can you reproduce with SeaMonkey v1.1.9 ?

*****

(In reply to comment #1)
> I also have the same problem, i'm running Firefox 2.0.0.12 (and older versions

Please, file a separate bug for your separate issue.
Keywords: crash
Version: unspecified → 1.7 Branch

Comment 3

11 years ago
I can't reproduce it because i'm not running Seamonkey, but there's something wrong with firefox on Linux 64 bits and flash sites, as there are no official flash plugin from Adobe, i'm using gnash, a free flash plugin, and in some sites that have flash applications firefox will crash but epiphany won't, so there's something in firefox. If you want i can tell you wich sites make Firefox crash
(In reply to comment #3)
> If you want i can tell you wich sites make Firefox crash

Yes, do file a separate bug for your separate/specific issue, with as much details as you have.

*****

(1 month later)

No reply from (initial) reporter.

(Would have been "Incomplete", now is) R.Invalid

Reopen if you can reproduce with SeaMonkey v1.1.9.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.