If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Crash when inserting after last() on external instance.

RESOLVED DUPLICATE of bug 310840

Status

Core Graveyard
XForms
--
critical
RESOLVED DUPLICATE of bug 310840
12 years ago
a year ago

People

(Reporter: Aurelian Penciu, Assigned: aaronr)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

24.12 KB, application/octet-stream
Details
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

The browser crashes when attempting to execute
<xf:insert nodeset="instance('itemlist1')/item" at="last()" position="after"/>.

The crash happens only on instances with external initial data.

Reproducible: Always

Steps to Reproduce:
1. Define an instance loaded with remote data like:
  <itemList>
    <item>i1</item>
  </itemList>
2. Add a trigger attempting to insert an item in the instance after last().
3. Clicking on the trigger crashes the browser.

Actual Results:  
Crash.

Expected Results:  
Define another instance with inline initial data. Steps 1-3 should work and a
new element should be appended to the list. The result should be similar if
initial instance data is external.
(Reporter)

Comment 1

12 years ago
Created attachment 199442 [details]
testcase

WAR tested on Tomcat 5.5 and J2SE 5.

URL: http://localhost:8080/XFIssues/insertCrash.xhtml

Left side shows an instance with external instance data. Clicking on buttons 1
nad 3 should crash the browser. Right side shows an instance with inline data.
All buttons work as expected.

Comment 2

12 years ago
Got a talkback ID for the crash?
Severity: normal → critical

Comment 3

12 years ago
Can you attach the generated XForms?
(Assignee)

Comment 4

12 years ago
You're right, this is still a bug on the preview.  It was fixed in the trunk in
bug 310840 and will be in our next branch (beta) update.  Or you can try this on
the latest nightly browser and matching nightly xforms.xpi if you want to make
sure for yourself that it fixes your problem.

*** This bug has been marked as a duplicate of 310840 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> You're right, this is still a bug on the preview.  It was fixed in the trunk in
> bug 310840 and will be in our next branch (beta) update.  Or you can try this on
> the latest nightly browser and matching nightly xforms.xpi if you want to make
> sure for yourself that it fixes your problem.
> 
> *** This bug has been marked as a duplicate of 310840 ***

I Agree. Just tested Deerpark Alpha2 (Mozilla/5.0 (Windows; U; Windows NT 5.1;
en-US; rv:1.9a1) Gecko/20051013 Firefox/1.6a1) with the matching XForms plugin
and the problem is solved.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.