Animated Gifs are NOT animated independantly for the same image

RESOLVED DUPLICATE of bug 287546

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 287546
12 years ago
5 years ago

People

(Reporter: Dave Morehouse, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

When dynamically adding animated gifs to a web page all the gifs have the same
animation state.  They are not animated independantly if they are started at
different times.  This really causes problems when the animated gif doesn't loop
because all gifs added after the end of the animation only show the last frame.

Reproducible: Always

Steps to Reproduce:
1. Run the html page that I'm attaching
2. Click the "Animated" button (notice that after a certain point all added
images don't animate at all)
3. Refresh the page
4. Click the "Animated Looped" button (notice that while the images continue to
animate, that they all share the same state instead of all starting from the
same frame).
Actual Results:  
All the animated gifs that are shown at any given time all use the same state. 
I would expect each image to be animated independantly. 

Expected Results:  
With IE (which I certainly realize isn't W3C) all animated gifs are animated
independantly.
(Reporter)

Comment 1

12 years ago
Created attachment 199461 [details]
A web page that reproduces the problem.
(Reporter)

Comment 2

12 years ago
Created attachment 199462 [details]
An animated gif that doesn't loop.
(Reporter)

Comment 3

12 years ago
Created attachment 199463 [details]
An animated gif that does loop.

Comment 4

12 years ago
Can confirm!

A variation of this bug: Loop once animated gifs are only played once even if
they are loaded later on on different subpages of a site with same (if same url
to the animated gif is used). That means the animation stays on the last frame -
looks like the image is cached and won't be run from frame 1 again even on a new
page. Only Ctrl-F5 can persuade the animation to start again.

Comment 5

12 years ago
Probably this is not a bug but a feature. "Caching" the animations saves memory
- but does not produce propper rendering results...
(Reporter)

Comment 6

12 years ago
If something doesn't render properly it's a bug.  A feature would be "Add
Animated Gif Support".  However that feature has already been added but doesn't
properly work.  What "feature" would you propose?  If the answer is "Make
animated gifs render properly" that sounds more like a bug to me.

Comment 7

12 years ago

*** This bug has been marked as a duplicate of 287546 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.