Feature request: rendercomplete event

RESOLVED WORKSFORME

Status

()

Core
Layout
--
enhancement
RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: Fritz Schneider, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

The canvas tag is really useful, especially for taking snapshots/thumbnails/etc
of web pages. However in order to get a meaningful render of a window to canvas,
the window has to be rendered (obviously). The problem is that there is no event
that signals this is the case. If you hook pageshow or load, there's no
guarantee that the page is actually displayed yet, so it could be that you
render a blank page to canvas :(

Yes, you can hack around using a delay of 500ms or whathaveyou, but how ugly is
that?

I'm told this could be useful for benchmarking as well.

Reproducible: Always
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: unspecified → Trunk
Using onload works fine for me now that bug 328541 is fixed.

Please reopen if it doesn't work for you, but then explain exactly what the setup is.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.