File downloads fail with "Failed to Save File" when Content-Encoding: gzip is present when it shouldn't be

RESOLVED DUPLICATE of bug 230153

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 230153
13 years ago
13 years ago

People

(Reporter: Josh Green, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051013 Galeon/1.3.21
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.12) Gecko/20051013 Galeon/1.3.21

When trying to download some files I get the following error dialog:
Failed to Save File.
/tmp/tnpv1lvh could not be saved, because the source file could not be read.
Try again later, or contact the server administrator.

This occurs in Mozilla and dependent browsers like galeon and epiphany.  I
believe I have tracked down the issue to the HTTP header "Content-Encoding:
gzip".  In all problem cases this header was received by the server and the
content is not actually gzip data.  I believe the server is sending this header
because of the presence of the .gz extension in the file name (perhaps an apache
server bug?).
Another problem file here (its a SourceForge.net download so pick a mirror):
http://prdownloads.sourceforge.net/swami/libinstpatch-1.0.0beta-20040917.tar.gz.asc?download

I noticed that this same issue causes text-plain mimetype files to just display
a blank page if the gzip encoding header is erroneously sent by the server (when
it is in fact not gzip data).

Reproducible: Always

Steps to Reproduce:
1. Try to download the URL mentioned in the problem URL field

Actual Results:  
The error dialog was displayed or in the case of text-plain mimetype files, a
blank page is displayed with no error message.

Expected Results:  
Detected that the content is not actually gzip or just allow the user to save it
to a file.

Comment 1

13 years ago
dupe of 'Content-Encoding: gzip page that isn't gzipped shows "source file could
not be read"'

*** This bug has been marked as a duplicate of 230153 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.