Accept languages empties when IE profile migration is selected.

VERIFIED FIXED in Firefox 2

Status

()

Firefox
Migration
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: Hiro, Assigned: Hiro)

Tracking

(4 keywords)

Trunk
Firefox 2
x86
Windows XP
fixed1.8.1, intl, jp-critical, verified1.8.0.2
Points:
---
Bug Flags:
blocking1.8.0.2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [tjp-dl], URL)

Attachments

(3 attachments)

(Assignee)

Description

13 years ago
Reproducible: Always
Steps to Reproduce:
1.Profile migration of IE is selected by making new profile. 
2.Open Tools -> Options -> Advanced -> General ->  Edit Languages

Actual Results:
 The Language list is empty. 

Expected Results:
The IE setting migrate.

Windows XP SP1 + IE6
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051013
Firefox/1.4.1
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051013
Firefox/1.4.1 ID:2005101321

Works for me.
Summary: Accept languages empties when IE profile migration is selected. → Accept languages empties when IE profile migration is selected.
(Assignee)

Comment 2

13 years ago
Created attachment 200577 [details]
screen shot of IE "Priority order of language"

The setting of IE is a Japanese, English order like the screen shot.
(Assignee)

Comment 3

13 years ago
Created attachment 200578 [details]
screen shot of Firefox languages box

As for the setting of IE, Migrate is not done to Firefox like the screen shot.
(Assignee)

Comment 4

13 years ago
In TranslateLanglist(), 'dest' is not correctly increment.
Therefore, the registry key to IE is not correctly copied. 
 
260   while (source < sourceEnd && *source && dest < destEnd) {
261     if (*source == ',')
262       skip = PR_FALSE;
263     else if (*source == ';')
264       skip = PR_TRUE;
265     if (!skip) {
266       if (comma && *source != ' ')
267         *dest++ = ' ';
268       *dest = *source;
269     }
270     comma = *source == ',';
271     ++source;
272   }
273   *dest = 0;
274 
275   prefs->SetCharPref(aPrefKeyName, prefStringValue);
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 5

13 years ago
Created attachment 203588 [details] [diff] [review]
Quick patch

The character string copy works normally. 
But because it doesn't have the development environment of Windows, it doesn't 
understand whether to work with Windows.
Assignee: nobody → crot0
Flags: blocking1.8.1?
Comment on attachment 203588 [details] [diff] [review]
Quick patch

Good! This patch works fine! Thank you for you work.
Attachment #203588 - Flags: review+
Attachment #203588 - Flags: superreview?(mconnor)
Status: NEW → ASSIGNED
Flags: blocking1.8.0.2?
Flags: blocking-firefox2?

Updated

13 years ago
Attachment #203588 - Flags: superreview?(mconnor) → superreview+
checked-in to Trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Comment on attachment 203588 [details] [diff] [review]
Quick patch

The risk is low. The migrator bugs are important for marketing. Let's go to fix on the branches.
Attachment #203588 - Flags: approval1.8.1?
Attachment #203588 - Flags: approval1.8.0.2?
Target Milestone: --- → Firefox 2
Version: 1.5 Branch → Trunk

Updated

13 years ago
Attachment #203588 - Flags: approval1.8.1? → branch-1.8.1?(mconnor)

Updated

13 years ago
Attachment #203588 - Flags: branch-1.8.1?(mconnor) → branch-1.8.1+
checked-in to 1.8 branch.
Flags: blocking-firefox2?
Keywords: fixed1.8.1, intl
Keywords: jp-critical
Flags: blocking1.8.0.2? → blocking1.8.0.2+
Comment on attachment 203588 [details] [diff] [review]
Quick patch

approved for 1.8.0 branch, a=dveditz for drivers
Attachment #203588 - Flags: approval1.8.0.2? → approval1.8.0.2+
Keywords: fixed1.8.0.2
This bug still exists when the build uses official branding.
I separated the issue to bug 327303.
-> v.
Status: RESOLVED → VERIFIED

Updated

13 years ago
Whiteboard: [tjp-dl]
Keywords: fixed1.8.0.2 → verified1.8.0.2
You need to log in before you can comment on or make changes to this bug.