Tab from recipient field doesn't access header types (compose)

VERIFIED DUPLICATE of bug 63889

Status

MailNews Core
Composition
P3
normal
VERIFIED DUPLICATE of bug 63889
19 years ago
10 years ago

People

(Reporter: laurel, Assigned: varada)

Tracking

({access})

Trunk
Future
access

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

19 years ago
Continued issue from bug #10932

Using mar09 commercial m15 builds for linux rh6.0, NT 4.0 and mac OS 9.0

There is currently no way to access and change the addressee header types
dropdown menu in the compose window.

March 09 comments by ducarroz in bug #10932 state: " ... Now when you tab from a
recipient field, the cursor jump into the next recipient type popup menu on the
next row and if you tab one more time the cursor is now into the next recipient
field. If you where already in the last recipient field, pressing tab put the
focus into the subjet...."

The above is not true, tabbing from recipient field never goes to the next
recipient field's header type menu. (And how would a user get to the first
recipient fields's header type menu?)

MAIN ISSUE FOR THIS BUG:
1.  We never get tab access to the header type, doesn't matter how many times
you tab from another recipient field. 

SIDE ISSUES WHICH MAY NEED TO BE REFERRED TO SEPARATELY:
2.  We never get any arrow key access to the header types menu.
3.  Once we get keyboard access working to the header types menu, we need to
have arrow key access to move between header types and select.
4.  We need access to the first line's header types.
5.  We need to decide the way in which we will access the next NEW recipient
line's header types.  Currently:
      a.  if you type one addressee but don't hit return, a tab will take you to
the subject line 
      b.  if you type one addressee and you hit return, a new address line is
opened but you have no keyboard access to change that new line's header.
(Reporter)

Updated

19 years ago
QA Contact: lchiang → laurel

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M15

Comment 1

19 years ago
Mass moving to M16 to get these off the M15 radar.  Please let me know if this
is really an M15 stopper.
Target Milestone: M15 → M16

Comment 2

19 years ago
we probably don't need this for M16.  Though I agree we will need this eventually.

Comment 3

18 years ago
Cleanup work, marking M18.
Target Milestone: M16 → M18

Comment 4

18 years ago
Added "nsbeta3" and "correctness" keywords.
Keywords: correctness, nsbeta3

Updated

18 years ago
Keywords: mail2

Comment 5

18 years ago
- per mail triage

Kevin - if you don't agree, please note in this bug. 
Whiteboard: [nsbeta3-]
Target Milestone: M18 → Future
(Assignee)

Comment 6

18 years ago
Reassigning bugs to varada
Assignee: ducarroz → varada
Status: ASSIGNED → NEW
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED

Comment 7

18 years ago
sorry for the extra email. Removing mail2 keyword.
Keywords: mail2

Comment 8

18 years ago
I can't figure out how to cc someone using only the keyboard.  Adding access 
keyword and nominating for nsbeta1.  See also bug 49217 and bug 63889 (this bug 
might get fixed in either of those bugs).
Keywords: access, nsbeta1

Comment 9

18 years ago
I know this bug came first, but I'd like to consider 63889 the bug that's going
to get looked at so marking this as a dup of that.

*** This bug has been marked as a duplicate of 63889 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 10

18 years ago
verifeid as duplicate
Status: RESOLVED → VERIFIED
QA Contact: laurel → pmock
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.