implementation of css3 property 'opacity' is wrong, should not be inherited

RESOLVED DUPLICATE of bug 250273

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 250273
12 years ago
10 years ago

People

(Reporter: mozillaBugzilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Firefox 1.07 renders elements via the css3 property 'opacity' incorrectly. 
While the Mozilla Developer Center suggests that this is proper
(http://developer.mozilla.org/en/docs/Useful_CSS_tips:Color_and_Background), the
CSS 3 Specification for transparency
(http://www.w3.org/TR/2003/CR-css3-color-20030514/#transparency) says that the
property should not be inherited.

Reproducible: Always

Steps to Reproduce:
1. use css 'opacity' property
2. look at children elements
3. realize its improperly implemented

Actual Results:  
child elements were transparent

Expected Results:  
not made child elements transparent
It isn't inherited but it does affect all descendants.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Resolution: INVALID → DUPLICATE
Duplicate of bug: 250273
You need to log in before you can comment on or make changes to this bug.