Firefox crashed while installing extension [@ ntdll.dll + 0x10f2b]

RESOLVED WORKSFORME

Status

Core Graveyard
Installer: XPInstall Engine
--
critical
RESOLVED WORKSFORME
13 years ago
3 years ago

People

(Reporter: Marc Bejarano, Unassigned)

Tracking

({crash})

1.8 Branch
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

firefox 1.5b2 crashed while installing v4.0.1 of the launchy extension.  the
next installation attempt was successful, but now i have a phantom "luanchy.xpi"
entry in my extension manager that grays out all buttons, including "uninstall" :(

the talkback is TB10591954H

Reproducible: Couldn't Reproduce
The crash occurred in xpinstall.
Assignee: nobody → xpi-engine
Component: Extension/Theme Manager → Installer: XPInstall Engine
Product: Firefox → Core
QA Contact: extension.manager
Version: 1.0 Branch → 1.8 Branch
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

13 years ago
Incident ID: 10591954
Stack Signature	ntdll.dll + 0x10f2b (0x7c910f2b) 67186552
Product ID	Firefox15
Build ID	2005100614
Trigger Time	2005-10-12 23:00:16.0
Platform	Win32
Operating System	Windows NT 5.1 build 2600
Module	ntdll.dll + (00010f2b)
URL visited	
User Comments	i tried to install the extension launchy v4.01 from the
developer's web site and it crashed after downloading the .xpi and pressing the
"install" button.
Since Last Crash	55448 sec
Total Uptime	55448 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
ntdll.dll + 0x10f2b (0x7c910f2b)
ntdll.dll + 0x10d5c (0x7c910d5c)
msvcrt.dll + 0x1c2de (0x77c2c2de)
operator delete
InstallFinalizeInstall 
[c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/xpinstall/src/nsJSInstall.cpp,
line 829]
js_Invoke 
[c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c,
line 1163]
js_Interpret 
[c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c,
line 3487]
js_Execute 
[c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jsinterp.c,
line 1394]
JS_EvaluateUCScriptForPrincipals 
[c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jsapi.c, line
4119]
JS_EvaluateUCScript 
[c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jsapi.c, line
4097]
JS_EvaluateScript 
[c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/js/src/jsapi.c, line
4065]
RunInstallOnThread 
[c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/xpinstall/src/nsSoftwareUpdateRun.cpp,
line 560]
_PR_NativeRunThread 
[c:/builds/tinderbox/Fx-Mozilla1.8/WINNT_5.2_Depend/mozilla/nsprpub/pr/src/threads/combined/pruthr.c,
line 458]
kernel32.dll + 0xb50b (0x7c80b50b)
Keywords: crash
Summary: firefox crashed while installing extension → Firefox crashed while installing extension [@ ntdll.dll + 0x10f2b]
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051015
Firefox/1.4.1 ID:2005101523

WFM.
(Reporter)

Comment 4

12 years ago
i got comment via email:
---
From: Wayne <vseerror@xxxx>
To: bmo@beej.org
Subject: Bug 312535 – Firefox crashed while in stalling extension [@ ntdll.dll + 0x10f2b]

Marc
do you still see this with FF v2?
 if gone please estimate when it went a way
 if still seen, please supply new talkback id

when you update the bug, please cc: me
--

wayne: i have no idea why you're not just adding a comment directly to the bug.  that's why the support for that exists :)  people often send their bugzilla email address to the bitbucket because they're suck spam magnets.

anyway, i never saw this crash again and using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2 ID:2007021917, i was just able to remove the Luanchy entry from the add-ons manager.

marking Closed WFM
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ ntdll.dll + 0x10f2b]
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.