RDF datasources in XUL can not be accessed if authentication is needed.

RESOLVED DUPLICATE of bug 33206

Status

RESOLVED DUPLICATE of bug 33206
13 years ago
2 months ago

People

(Reporter: christian.schaefer, Unassigned)

Tracking

1.8 Branch
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

it's very similar to the bug I filed earlier:
https://bugzilla.mozilla.org/show_bug.cgi?id=312473

this time I tried to use an external RDF datasource on a XUL tree that is
protected by HTTP authentication.

in my case the datasource is requested via javascript using
nsIRDFService.GetDataSourceBlocking().

Reproducible: Always

Steps to Reproduce:
1. write a XUL file with ie a tree or a list that uses an external rdf as
datasource.
2. protect that datasource with http authentication (ie .htaccess)
3. load your xul file and see if it loads the datasource.

Actual Results:  
the datasource is not loaded.
instead you will get the following error message in the javascript console:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004002 (NS_NOINTERFACE) [nsIRDFService.GetDataSourceBlocking]"  nsresult:
"0x80004002 (NS_NOINTERFACE)"  location: "JS frame ::
chrome://horrorado/content/js/overlay_tab_app_media_init.js :: populate_init ::
line 81"  data: no]

Expected Results:  
I would have expected that the common auth dialog box would appear and that the
datasource would be loaded after authenticating or throw an error if that failed.

why would I need that?
as in that other mentioned bug I filed I am working on an extension for a client.
this extension will be an administrational tool for the webshop they run.
obviously an administration tool should not be public.
this tool will get the shopt data using several rdf files from the web server.
since these also contain client information they would need to be protected
against public access. easiest way to do that is using http authentication.

unfortunately that does not work..
The extension / theme manager manages extension / theme installs, upgrades,
uninstall, etc. but not the interaction of the extension with interfaces, ui,
etc. - fixing product and component.
Component: Extension/Theme Manager → RDF
Product: Firefox → Core
QA Contact: extension.manager → rdf
Version: unspecified → 1.8 Branch
(Reporter)

Comment 2

13 years ago
fair enough. thanks for putting this right.
I haven't seen this category..

Comment 3

13 years ago
This is a DUPE of bug 33206.

*** This bug has been marked as a duplicate of 33206 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

2 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.