Closed Bug 31256 Opened 22 years ago Closed 20 years ago

Problems with border-collapse and tables

Categories

(Core :: Layout: Tables, defect, P3)

x86
All
defect

Tracking

()

VERIFIED DUPLICATE of bug 41262
mozilla1.0

People

(Reporter: limi, Assigned: karnaze)

References

()

Details

(Keywords: css2, testcase, Whiteboard: likely dups: 26614; also 2130, 12462, 22897)

The upper and left borders go missing when using border-collapse (CSS2), as do 
the ones inside the table. There's also a stray pixel in the upper right and 
lower left corner. These "features" only appear when the table has background-
color set. Check out the URL for an example with pictures.
Changing component
Assignee: troy → karnaze
Component: Layout → HTMLTables
QA Contact: petersen → chrisd
I use build 2000022820 on Wintendo 2000
Keywords: css2
OS: Windows 2000 → All
Summary: Problems with border-collapse (CSS2) and tables → Problems with border-collapse and tables
Whiteboard: likely dups: 26614; also 2130, 12462, 22897
*** Bug 31442 has been marked as a duplicate of this bug. ***
Last time I looked at the source code for the collapsing border model, it was
pretty obvious why this was happening.  (It was noted in a comment at one of the
points where it was broken.)

But I think the fix may require rewriting that code completely (and even if it
doesn't, it might be a good thing).
Status: UNCONFIRMED → NEW
Ever confirmed: true
I am planning to rewrite the border collapse code in M16 but it might not happen 
until M17.
Status: NEW → ASSIGNED
Target Milestone: --- → M16
Looks better in build 2000050215 (M15), but is still wrong. Check the URL to 
see what I mean.
Moving to M17.
Target Milestone: M16 → M17

*** This bug has been marked as a duplicate of 41262 ***
Status: ASSIGNED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
I should have made a dependency instead of a dup. 
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → ASSIGNED
Depends on: 41262
Adding testcase keyword so this doesn't show up on the bugathon search page.
Keywords: testcase
Tested on M18. A bit better but still not correct. Check the URL to see what is 
wrong.
Target Milestone: M17 → ---
Moving to m1.0
Target Milestone: --- → mozilla1.0
QA contact update
QA Contact: chrisd → amar
Table border collapsing seems to have regressed to the point of not working at
all. Take a look at the cited URL for an example. I'll file a new bug if requested.

*** This bug has been marked as a duplicate of 41262 ***
Status: ASSIGNED → RESOLVED
Closed: 22 years ago20 years ago
Resolution: --- → DUPLICATE
Problems with border-collapse and tables were fixed. Marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.