trunk builderror with suse 10 / gcc 4 memset/memcpy

RESOLVED WORKSFORME

Status

()

Core
Build Config
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: Andreas Otte, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
Trying to build the trunk (firefox) on SuSE 10 with gcc 4.0.2. I'm getting the
following linker problem:

gmake[4]: Leaving directory `/home/mozilla/firefox/dbm/src'
gmake[4]: Entering directory `/home/mozilla/firefox/dbm/tests'
gcc -o lots -I/usr/X11R6/include -Wall -W -Wno-unused -Wpointer-arith
-Wcast-align -Wno-long-long -pedantic -pthread -pipe  -DNDEBUG -DTRIMMED -O
lots.o      -L../../dist/bin -L../../dist/lib -lmozdbm_s -ldl -lm
lots.o: In function `MakeLargeKey':
lots.c:(.text+0x108): undefined reference to `memset'
../../dist/lib/libmozdbm_s.a(hash.o): In function `__hash_open':
hash.c:(.text+0x6c): undefined reference to `memset'
../../dist/lib/libmozdbm_s.a(hash.o): In function `init_hash':
hash.c:(.text+0x4b3): undefined reference to `memset'
hash.c:(.text+0x4c6): undefined reference to `memset'
../../dist/lib/libmozdbm_s.a(hash.o): In function `hash_realloc':
hash.c:(.text+0x134c): undefined reference to `memset'
../../dist/lib/libmozdbm_s.a(hash_buf.o):hash_buf.c:(.text+0x20f): more
undefined references to `memset' follow
/usr/lib/gcc/i586-suse-linux/4.0.2/../../../../i586-suse-linux/bin/ld: lots:
hidden symbol `memset' isn't defined
/usr/lib/gcc/i586-suse-linux/4.0.2/../../../../i586-suse-linux/bin/ld: final
link failed: Nonrepresentable section on output
collect2: ld gab 1 als Ende-Status zurück
gmake[4]: *** [lots] Fehler 1
gmake[4]: Leaving directory `/home/mozilla/firefox/dbm/tests'
gmake[3]: *** [libs] Fehler 2
gmake[3]: Leaving directory `/home/mozilla/firefox/dbm'
gmake[2]: *** [tier_1] Fehler 2
gmake[2]: Leaving directory `/home/mozilla/firefox'
make[1]: *** [default] Fehler 2
make[1]: Leaving directory `/home/mozilla/firefox'
make: *** [build] Fehler 

configuring with --disable-tests moves the problem just to another place in the
tree and memcpy as the culprit. Which library am I missing? Or is this a gcc 4
problem?

Comment 1

13 years ago
There's this bug with compiling with gcc 4, see Bug 307168 and dupes of it. But
not sure if it is a dupe of it (a bit different error message)?
(Reporter)

Comment 2

13 years ago
Seems to be something different, no 64 bit for example. Played around with gcc
options a bit but had no luck.
(Reporter)

Comment 3

13 years ago
building with --disable-tests this is the next stop:

gmake[4]: Entering directory `/home/mozilla/firefox/modules/zlib/src'
rm -f libmozz.so
c++ -I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O -fPIC -shared -Wl,-h -Wl,libmozz.so -o libmozz.so  adler32.o compress.o crc32.o deflate.o gzio.o infback.o inffast.o inflate.o inftrees.o trees.o uncompr.o zutil.o        -ldl -lm
deflate.o: In function `MOZ_Z_deflateSetDictionary':
deflate.c:(.text+0x36e): undefined reference to `memcpy'
deflate.o: In function `flush_pending':
deflate.c:(.text+0x749): undefined reference to `memcpy'
deflate.o: In function `MOZ_Z_deflate':
deflate.c:(.text+0xf89): undefined reference to `memset'
deflate.o: In function `MOZ_Z_deflateCopy':
deflate.c:(.text+0x1253): undefined reference to `memcpy'
deflate.c:(.text+0x12e6): undefined reference to `memcpy'
deflate.c:(.text+0x12fd): undefined reference to `memcpy'
deflate.c:(.text+0x1314): undefined reference to `memcpy'
deflate.c:(.text+0x1325): undefined reference to `memcpy'
deflate.o:deflate.c:(.text+0x140b): more undefined references to `memcpy' follow
deflate.o: In function `lm_init':
deflate.c:(.text+0x145b): undefined reference to `memset'
deflate.o: In function `fill_window':
deflate.c:(.text+0x17fb): undefined reference to `memcpy'
gzio.o: In function `MOZ_Z_gzread':
gzio.c:(.text+0x80e): undefined reference to `memcpy'
gzio.o: In function `MOZ_Z_gzseek':
gzio.c:(.text+0xe53): undefined reference to `memset'
infback.o: In function `.L30':
infback.c:(.text+0x38e): undefined reference to `memcpy'
inflate.o: In function `updatewindow':
inflate.c:(.text+0x2c3): undefined reference to `memcpy'
inflate.c:(.text+0x305): undefined reference to `memcpy'
inflate.c:(.text+0x32a): undefined reference to `memcpy'
inflate.o: In function `.L76':
inflate.c:(.text+0xaa4): undefined reference to `memcpy'
inflate.o:inflate.c:(.text+0x111a): more undefined references to `memcpy' follow
/usr/lib/gcc/i586-suse-linux/4.0.2/../../../../i586-suse-linux/bin/ld: libmozz.so: hidden symbol `memcpy' isn't defined
/usr/lib/gcc/i586-suse-linux/4.0.2/../../../../i586-suse-linux/bin/ld: final link failed: Nonrepresentable section on output
collect2: ld gab 1 als Ende-Status zurück
gmake[4]: *** [libmozz.so] Fehler 1
gmake[4]: Leaving directory `/home/mozilla/firefox/modules/zlib/src'
gmake[3]: *** [libs] Fehler 2
gmake[3]: Leaving directory `/home/mozilla/firefox/modules/zlib'
gmake[2]: *** [tier_1] Fehler 2
gmake[2]: Leaving directory `/home/mozilla/firefox'
make[1]: *** [default] Fehler 2
make[1]: Leaving directory `/home/mozilla/firefox'
make: *** [build] Fehler 2
(Reporter)

Comment 4

13 years ago
Created attachment 200907 [details] [diff] [review]
not a fix, but a trick to get the build working again

This is a gcc 4 bug, which can be circumvented with the attached patch to configure, the real fix is to fix gcc 4 ...
(Reporter)

Comment 5

13 years ago
see bug 307168 for a longer discussion, it was the right hint 
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 6

13 years ago
I'm assuming you mean that one of the patches in bug 307168 fixed your problem.  If none of the actual patches to the code did, but you just picked up on a workaround, then this shouldn't really be resolved as FIXED.  WORKSFORME at best...
(Reporter)

Comment 7

13 years ago
reopen
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 8

13 years ago
marking WORKSFORME as requested
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.