tabulation stops are displayed wrong when the message contains Japanese character

RESOLVED DUPLICATE of bug 271163

Status

defect
RESOLVED DUPLICATE of bug 271163
14 years ago
14 years ago

People

(Reporter: u69748, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051015 Firefox/1.4.1
Build Identifier: 1.5 Beta 2 (20051015)

tabulation stops are displayed wrong when the message contains Japanese character.

Example:
12345678123456781234567812345678
	1	2	3
	1	2	3


Reproducible: Always

Steps to Reproduce:

Actual Results:  
12345678123456781234567812345678
------>1------>2------>3
------>1]------>2]------>3]

where,
------> is single tabulation stop
1], 2] and 3] are double-width digit


Expected Results:  
12345678123456781234567812345678
------>1------>2------>3
------>1]----->2]----->3]
(Reporter)

Comment 1

14 years ago
(Reporter)

Comment 2

14 years ago
(Reporter)

Comment 3

14 years ago
correction.

Actual Results:  
12345678123456781234567812345678
------->1------>2------>3
------->1]------>2]------>3]

where,
------> is single tabulation stop
1], 2] and 3] are double-width digit


Expected Results:  
12345678123456781234567812345678
------->1------>2------>3
------->1]----->2]----->3]

*** This bug has been marked as a duplicate of 271163 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.