Closed Bug 31265 Opened 20 years ago Closed 20 years ago

ebay sign in fails

Categories

(Core :: DOM: Core & HTML, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 18728

People

(Reporter: bschwab, Assigned: pollmann)

References

()

Details

when the username and password is submitted to sign in for ebay, it fails and says:

Input Error

There was an error in your input. Please go back and ensure that all fields are
properly filled in.
sounds like a submit issue
Assignee: rods → pollmann
*** Bug 31786 has been marked as a duplicate of this bug. ***
Same issue as in bug 29864?
*** Bug 29864 has been marked as a duplicate of this bug. ***
Thanks Sebastian, I think you're right.  I'll verify both of these when looking
at this bug.  Since three separate people have reported this, I'm marking it
new.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This is what we submit:

<headers>
Content-Length: 80

referrer=null&MfcISAPICommand=SignInWelcome&UsingSSL=0&userid=XXXX&pass=XXXXXX

This is what Nav submits:
<headers>
Content-length: 81

MfcISAPICommand=SignInWelcome&UsingSSL=0&userid=XXXX&pass=XXXXXX&referrer=+null

I notice two major differences.  One is that we are stripping the leading space
off of the "referrer" value so instead of submitting " null" like we should, we
are instead submitting "null".  This is bad, but is not preventing the login

The other major difference, and that preventing the login is that the bariables
are not submitted in the same order that they appear on the page.  This is
reported as bug 18728.  This is the first major site I've seen affected by the
bug, but along should bump up the priority of the bugfix.

Marking this a duplicate.

*** This bug has been marked as a duplicate of 18728 ***
Status: NEW → RESOLVED
Closed: 20 years ago
OS: Windows NT → All
Hardware: PC → All
Resolution: --- → DUPLICATE
verified dupe
Status: RESOLVED → VERIFIED
Component: HTML: Form Submission → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.