If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When displaying pages with the (GBP) £ symbol generated by a server script the values are displayed incorrectly.

RESOLVED DUPLICATE of bug 181344

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 181344
12 years ago
12 years ago

People

(Reporter: Liam Lowey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Character encoding is set to Western ISO-8559-1 with Autodetect->Univervisal
switched on. The problem occurs on a number of sites where the £ (GBP) currency
symbol is used in server generated pages. For example DHLs tarif and transit
search facility. The results returned are rendered with ?? marks, e.g. £40.40
became ??40. Manually setting the encoding (in this case to Unicode) appears to
remove the problem.

Reproducible: Sometimes

Steps to Reproduce:
1. Set encoding to (Autodetect->Universal) Western ISO-8559-1 (default).
2. Visit UK shop website and do a search which returns prices as part of the
results (e.g. DHL.co.uk, Tariff and Transit).
3. Results often returned as ?? instead of £

Actual Results:  
Displayed for example ??40

Expected Results:  
Should have displayed the correct price and symbols: £40.40

This problem does occasionally disappear if I do a full-restart of the browser.
Also if I change the character encoding.

*** This bug has been marked as a duplicate of 181344 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.