Uninstalling an extension while doing a "Find Updates" don't update the status text

RESOLVED FIXED in mozilla1.8.1alpha2

Status

()

Toolkit
Add-ons Manager
--
trivial
RESOLVED FIXED
13 years ago
10 years ago

People

(Reporter: François Gagné, Assigned: rstrong)

Tracking

({fixed1.8.1})

1.8.0 Branch
mozilla1.8.1alpha2
x86
Windows XP
fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: 0d (already completed as part of bug 329045))

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051012 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051012 Firefox/1.4.1

To trigger this bug you need a extension that will take a while to resolve his
update link (ex: Nightly Tester Tools) or that is update link is no more available.

There is 2 cases:
Case 1:
Uninstall an extension different then the one taking a while to resolve

Case 2:
Unistall the extension taking a while to resolve


Reproducible: Always

Steps to Reproduce:
Case 1 and 2:
1)Go in Tools->Extensions
2)Click "Find Updates..."
3)Before the extension taking a while to resolve finaly get the "No update were
found for _Extension Name_..." status

3a) Case 1: Click Uninstall on a different extension, it will be uninstalled but
the status won't be updated. (The uninstall button is disabled)
If you close the Extensions Manager and reopen it the status will be fine.

3b) Case 2: Click Uninstall on the extension taking a while to resolve, it will
be uninstalled but the status won't be updated.
Now here come the difference from case 1, if you close the Extensions Manager
and reopen it, the status text seems to be stuck to "Looking for updates to
_Extension Name_..."
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5 Branch
We should probably disable all commands while an update check is taking place.
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee: nobody → robert.bugzilla
Target Milestone: --- → Firefox 2 alpha2
Whiteboard: 0d (already completed as part of bug 329045)
Fixed on trunk by the checkin for bug 329045. While an update check is being performed commands like uninstall, disable, enable, etc. are not available now.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Keywords: fixed1.8.1
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.