Printing address book is extremely limited and not sorted according to "View | Sort by"

RESOLVED DUPLICATE of bug 118900

Status

Thunderbird
Address Book
--
enhancement
RESOLVED DUPLICATE of bug 118900
13 years ago
13 years ago

People

(Reporter: richardvallee, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr-FR; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Printing the full address book systematically prints in the same order,
regardless of the Sort by order chosen. The said order is incoherent and does
not seem to be based on either alphabetical order of name, display name or email.

Printing the full address book also offers extremely limited options regarding
layout and readability. Printing strictly over one column creates too much
whitespace and organization of the contacts information is not ergonomically
layed out.

Reproducible: Always

Steps to Reproduce:
1.Choose "File | Print Address book" (Or "File | Print Preview Address Book") in
the Address Book.

Actual Results:  
The print order is identical each time but based on criteria that are neither
customizable nor understandable. Some items seem to be in alphabetical order
while  others seem completely random (maybe based on entry order, I can't figure
out the actual order criteria).

Expected Results:  
Order should be determined by the one determined by the "File | Order by" menu
or the sortable labels above each column. In best scenario, such order should be
modifiable in the "Print preview dialog", exclusively for printout, without
affecting the displayed order in the Address Book.

Allow customization of layout, in regards to columns alignment, font and,
especially, order. Layout should at least allow different column organization
(2+ columns) to reduce white space, clearly identify the chosen order with
titles if possible (see same feature in Microsoft Outlook, which identifies each
letter with a clear bold, uppercase separatation between the alphabetical
sections when sorted with such order) as well as, wishfully also customizable,
the capacity to print item titles (i.e. the name of the contact) over a grayed
background, or similar identifiable text styling, to separate items in the same
section instead of lines between elements (again refer to Microsoft Outlook
contact list printout).

Such layout features could be wrapped in skinnable styles, CSS would certainly
be ideal for that, that could be customized as well as shared and downloaded.
Customization by CSS is ideal for advanced users while the packaging of such
styles, that could be shared and downloaded, would be very useful for standard
users who desire customized address book layout but have neither time nor
know-how to do it themselves.

Comment 1

13 years ago
Please stick to one bug per report, as it is easier for solutions to be
targetted.   The sort order of printing is bug 118900, whereas the other issues
I'm not so sure about.  

Comment 2

13 years ago
Customising printing looks like bug 120267.  Reporter, could you look at my two
dupe suggestions, and assuming that you agree these issues cover what you asked
for, mark as a dupe of one of them.  Thanks.
(In reply to comment #2)
> Customising printing looks like bug 120267.  Reporter, could you look at my two
> dupe suggestions, and assuming that you agree these issues cover what you asked
> for, mark as a dupe of one of them.  Thanks.

Marking as duplicate of bug 118900.

Reporter, if bug 120267 doesn't cover your customise request, please raise a seperate bug covering just that issue. That way it will be easier for bug tracking.

Thanks.

*** This bug has been marked as a duplicate of 118900 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.