SVG not supported in this example

RESOLVED INVALID

Status

()

Core
SVG
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Ray Salemi, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

This SVG page works properly in IE (it shows the expected block diagrams.) but
not in Firefox

Reproducible: Always

Steps to Reproduce:
1.Open the URL
2.Open the hierarchy to the left
3.click on a little yellow box.  You should see a block diagram on the right

Actual Results:  
3. Got a blank page on the right.

Expected Results:  
3.  Should have displayed SVG block diagram.

Comment 1

12 years ago
1) This is a SVG problem, Core->SVG

2) From the provided link:

<EMBED ID="SVGID" NAME="transform" WIDTH="914" HEIGHT="677" SRC="struct_bd.svg"
PLUGINSPAGE="http://www.adobe.com/svg/viewer/install/">

The problem is that there is no type specify: type='image/svg+xml'

3) Probably a duplicate of bug 307942

The web server should also serve the svg as image/svg+xml rather than text/plain.

Even if the mime type issues are fixed the svg uses xlink but does not define
xmlns:xlink i.e. it
needs xmlns:xlink="http://www.w3.org/1999/xlink" adding as an attribute to the
<svg> element.

Assignee: nobody → general
Component: General → SVG
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.8 Branch
Yes, there are bugs in the content, not in Mozilla. Ray, for information on why
SVG content fails in Mozilla please see the following documents. If you can,
please contact the maintainers of websites that make these mistakes and ask them
to correct them. It won't be long after Firefox 1.5 is released before it will
have as big an install base as ASV, so it's in their interest to make the changes.

  http://jwatt.org/svg/authoring/
  http://www.mozilla.org/projects/svg/faq.html

Marking invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.