If a profile cannot be found on disk, message incorrectly states "Profile in use"

VERIFIED DUPLICATE of bug 278860

Status

()

defect
VERIFIED DUPLICATE of bug 278860
14 years ago
11 years ago

People

(Reporter: sfennell, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050427 Red Hat/1.7.7-1.1.3.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050427 Red Hat/1.7.7-1.1.3.4

I have my profiles on a removable drive.  If that drive is not accessible for
some reason the profile manager doesn't give proper notification that the
profile cannot be found.  Instead the profile manager says "Profile already in
use"  Which is incorrect.  I would like more intelligent profile messages for
when profiles cannot be found.

Reproducible: Always

Steps to Reproduce:
1. create a profile on a removable drive
2. disconnect removable drive (or delete profile directory without deleting
profile entry)
3. start firefox and choose the profile just created.  

Actual Results:  
I get a message saying the "Profile is in use"

Expected Results:  
The message should be smart enough to say "Profile cannot be found on disk"

*** This bug has been marked as a duplicate of 278860 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.