open New Composer from Open Web Location dialog crashes browser

VERIFIED FIXED in M14

Status

SeaMonkey
UI Design
P3
critical
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Dan M)

Tracking

({crash, pp})

Trunk
Other
Linux
crash, pp

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] MUST FIX (linux only), URL)

(Reporter)

Description

18 years ago
tested using opt comm bits 2000.03.09.13 on linux.

1. bring Open Web Location dialog.
2. enter the above URL, select open in New Composer window radio button.
3. click Open.

result: outline of Composer window is drawn, then browser crashes.
expected: shouldn't crash; should happily load page in a new composer window.
note that this isn't a problem if i go to File > Edit Page (currently File > d
;-)

talkback info:
http://cyclone/reports/incidenttemplate.CFM?reportID=124&style=0&tc=51&cp=1&ck1=SUser+email+address&cd1=%25sairuh%40netscape%2Ecom%25&co1=like&bbid=6584561


 Trigger Type:  Program Crash 

 Trigger Reason:  SIGSEGV: Segmentation Fault: (signal 11) 

 Call Stack:    (Signature = libwidget_gtk.so + 0x353df (0x4153f3df) 04681c89) 
     
  libwidget_gtk.so + 0x353df (0x4153f3df) 
                                           
     
  libwidget_gtk.so + 0x36afb (0x41540afb) 
                                           
     
  libwidget_gtk.so + 0x3c1d7 (0x415461d7) 
                                           
     
  libgfx_gtk.so + 0x142b0 (0x416282b0) 
                                           
     
  libwidget_gtk.so + 0x4018e (0x4154a18e) 
                                           
     
  libwidget_gtk.so + 0x3aa11 (0x41544a11) 
                                           
     
  libwidget_gtk.so + 0x3ab9f (0x41544b9f) 
                                           
     
  libwidget_gtk.so + 0x3a8e9 (0x415448e9) 
                                           
     
  libglib-1.2.so.0 + 0x10ba9 (0x405a4ba9) 
                                           
     
  libglib-1.2.so.0 + 0xfbe6 (0x405a3be6) 
                                           
     
  libglib-1.2.so.0 + 0x101a1 (0x405a41a1) 
                                           
     
  libglib-1.2.so.0 + 0x10341 (0x405a4341) 
                                           
     
  libgtk-1.2.so.0 + 0x8c209 (0x404cb209) 
                                           
     
  libwidget_gtk.so + 0x255aa (0x4152f5aa) 
                                           
     
  libnsappshell.so + 0x140e2 (0x40f580e2) 
                                           
     
  mozilla-bin + 0x2f2c (0x0804af2c) 
                                           
     
  mozilla-bin + 0x324c (0x0804b24c) 
                                           
     
  libc.so.6 + 0x181eb (0x4021d1eb)
(Reporter)

Comment 1

18 years ago
came from discussion in bug 24903...

danm, have you seen this occur on platforms other than linux? i haven't been
able to repro on winNT [2000.03.09.08 opt comm bits] or macOS [2000.03.09.13 opt
non-comm bits].
Keywords: beta1, crash, pp
QA Contact: paulmac → sairuh
(Assignee)

Comment 2

18 years ago
This problem seems confined to only Linux among the Three. Note this is almost 
certainly the same problem, and therefore the same bug, as 24903.
(Reporter)

Comment 3

18 years ago
same even though the stack info is different? just curious --thanks!

Comment 4

18 years ago
Putting on PDT+ radar for beta1 to disable, similar to 24903.
Whiteboard: [PDT+]w/b minus on 03/10

Comment 5

18 years ago
If this is the same as bug #24903, then why the Hell do I have the bug?
Assignee: don → danm
(Assignee)

Comment 6

18 years ago
  Yes, the stack traces are different enough that it's worth keeping both open. 
But it's likely that the real problem is a set of conditions created way before 
anything mentioned in the stack traces.
  A note of clarification about leger's comment is in order here, as in the 
sibling bug. The most likely way to disable this functionality is to change the 
two radio buttons to "Don't select me" and "Don't select me either".  Or maybe 
disable the OK button, leaving only Cancel.
Status: NEW → ASSIGNED
(Reporter)

Comment 7

18 years ago
unlike sibling bug 24903, this is a regression w/respect to 4.72 (on linux). ah,
more keywords.
Keywords: 4xp

Comment 8

18 years ago
Can I have an update on the status of this bug?  Progress? plans? comments?
Thanks,
Jim

Comment 9

18 years ago
Feeling nervous about this bug... I decided to add mscott and pav to the fray
(cc list).
This sure sounds a lot like 24903.  Both involve ONLY linux.  Both involve new
browser windows.
We need to know if there is a work-around, and we can grey out an access to this
functionality to ship beta.  If we can't, then this bug becomes a MUST FIX.
Comments???
Thanks,
Jim
(Assignee)

Comment 10

18 years ago
You should be nervous about this bug. The root cause is mysterious and awful. I 
still can't name it. But the crash can be shooed off by application of clever 
hunch. This is fixed on the trunk. I'll move it over to M14 next week, after I 
manage to thread all the appropriate bureaucratic tangles.
Whiteboard: [PDT+]w/b minus on 03/10 → [PDT+]w/b minus on 03/10 [fixed on trunk]
(Assignee)

Comment 11

18 years ago
.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+]w/b minus on 03/10 [fixed on trunk] → [PDT+]w/b minus on 03/10
(Reporter)

Comment 12

18 years ago
tested using 2000.03.13.03 optimized commercial bits on linux. no longer get a
crash, but instead the composer window appears and remains grey [blank]. had to
kill the new composer window. reopening.

was the fix supposed to be in this build am testing...?

here's the console output (starting from when i open the Open Web Location
dialog):

WEBSHELL+ = 5
Move window by 411.5,125.2
screen x 17screen y 16
WEBSHELL+ = 6
WEBSHELL+ = 7
WEBSHELL- = 6
warning: attempted to CreateNative() without a superwin parent

Gtk-WARNING **: invalid cast from (NULL) pointer to `GtkObject'

Gtk-WARNING **: invalid cast from (NULL) pointer to `GtkObject'
Doing Editor Startup...
Trying to make an Editor Shell through the component manager...
Created nsEditorShell
Attaching to WebShellWindow[_blank]
JavaScript Error: uncaught exception: [Exception... "Component returned failure
code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIEditorShell.SetContentWindow]" 
nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame ::
chrome://editor/content/EditorCommands.js :: EditorStartup :: line 104"  data:
no]

WEBSHELL- = 5

Gdk-CRITICAL **: file gdkwindow.c: line 1707 (gdk_window_get_parent): assertion
`window != NULL' failed.

Gdk-CRITICAL **: file gdkwindow.c: line 1707 (gdk_window_get_parent): assertion
`window != NULL' failed.
got a request
JavaScript Error: uncaught exception: [Exception... "Component returned failure
code: 0x80004002 (NS_NOINTERFACE) [nsIEditorShell.CheckAndSaveDocument]" 
nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame ::
chrome://editor/content/EditorCommands.js :: EditorCanClose :: line 368"  data:
no]

In EditorShutdown..
WEBSHELL- = 4
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 13

18 years ago
note: bits came from the 2000.03.13.03.M15-nb1b branch.
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+]w/b minus on 03/10 → [PDT+] MUST FIX (linux only) -- see status bug 24903
(Assignee)

Comment 14

18 years ago
Branch works like trunk now.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+] MUST FIX (linux only) -- see status bug 24903 → [PDT+] MUST FIX (linux only)
(Assignee)

Updated

18 years ago
Target Milestone: M14
(Reporter)

Comment 15

18 years ago
works now; verif using linux [2000.03.13.19-nb1b, opt comm].
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.