body { background-position: bottom; } positions relative to content area, not with window edge

RESOLVED DUPLICATE of bug 243751

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 243751
12 years ago
12 years ago

People

(Reporter: FLEB, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

In the page shown, there should be a background image (a rubber duck) in the
lower righthand side. However, the "background-position: bottom right" CSS rule
in "body" (included inline) does not line up the image with the bottom right
corner of the window, but with the bottom right corner of <body>'s content. The
duck is to the right side of the window, but only as far down as the <body>
content extends.

I have tried this in both IE (6.0) and Mozilla (1.7.7), and have gotten the
expected behavior (the duck at the lower-right of the window), so I am assuming
that it is a rendering bug and not simply my misunderstanding of the CSS directive.

Firefox (via the Web Developer Extension) reports that it is running in
Standards-Compliant mode. The document is written in XHTML Transitional, and
both CSS and XHTML are valid by the W3C validators.

Reproducible: Always

Steps to Reproduce:
Include a "bottom" positioned background image in a page where the body content
is shorter than the window.
Actual Results:  
The background image rests on the bottom of the body's content area.

Expected Results:  
The background should rest on the bottom of the window, if the body's content
area is smaller than the area of the window.

*** This bug has been marked as a duplicate of 243751 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.