Fails to start when general.useragent.override set to MSIE

RESOLVED DUPLICATE of bug 83376

Status

()

defect
RESOLVED DUPLICATE of bug 83376
14 years ago
11 years ago

People

(Reporter: james.mdb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

if you set the preference general.useragent.override to "MSIE 7.0b", the next
time you open Firefox you get a "Java Plug-in Error"

"Java Plug-in for Netscape Navigator should not be used in Microsoft Internet
Explorer.
Please use Java Plug-in for Microsoft Internet Explorer instead."

solved by removing the line from prefs.js

Reproducible: Always

Steps to Reproduce:
1. open prefs.js
2. add the line user_pref("general.useragent.override", "MSIE 7.0b");
3. open Firefox

message box appears
Actual Results:  
---------------------------
Java Plug-in Error
---------------------------
Java Plug-in for Netscape Navigator should not be used in Microsoft Internet
Explorer.
Please use Java Plug-in for Microsoft Internet Explorer instead.
---------------------------
OK   
---------------------------


Expected Results:  
The Java Plug-in for NN should not depend on the user-agent string.

-and/or-

general.useragent.override should only apply to HTTP Requests, and not be
visible to plug-ins.

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.