OE/Mac can't understand mozilla mail

NEW
Unassigned

Status

MailNews Core
Composition
P3
normal
18 years ago
8 years ago

People

(Reporter: Akkana Peck, Unassigned)

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: outlook)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
I typed a message in mozilla/linux using the html compose window, with my pref
set to always convert to plaintext on send.

One recipient sent me this.  Is it the format=flowed that's confusing OE?  I've
edited out the Received-by headers.

----------------------
My mailer (OE Mac version 5) said "Some text in this message is in a language
your computer cannot display". Other than that it looked fine.

Here are all the headers in case they're useful:

> Return-Path: <owner-psc@seds.org>
> Received: from mx1.znet.com (mx.znet.com [207.167.64.1])
> by sj.znet.com (8.10.0/8.10.0/jjb-sj) with ESMTP id e2A09SE08075;
> Thu, 9 Mar 2000 16:09:28 -0800 (PST)
> Message-ID: <38C83D19.9010003@netscape.com>
> Date: Thu, 09 Mar 2000 16:08:57 -0800
> From: akkana@netscape.com (Akkana Peck)
> User-Agent: Mozilla/5.0 (X11; N; Linux 2.2.5-22 i686; en-US; m14)
> Netscape6/6.0b1 > X-Accept-Language: en
> MIME-Version: 1.0 > To: psc@seds.org
> Subject: Re: [PSC] PSC Night
> References: <4.2.0.58.20000309154627.00ab2580@cupmail0.rational.com>
> Content-Type: text/plain; charset=us-ascii; format=flowed
> Content-Transfer-Encoding: 8bit
> X-MIME-Autoconverted: from quoted-printable to 8bit by seds.lpl.arizona.edu id
> RAA08762 > Sender: owner-psc@seds.org
> Precedence: bulk
> Reply-To: psc@seds.org
> X-UIDL: 6a8f918e313807c76dfdbd9b10de7fd2
reassign to rhp
Assignee: ducarroz → rhp

Comment 2

18 years ago
I know that Outlook Express can deal with our format=flowed/quoted printable 
email messages...I test with OE from time to time on MIME interoperability.

I think this is the culprit:

X-MIME-Autoconverted: from quoted-printable to 8bit by seds.lpl.arizona.edu id

Looks like they have some sort of service to convert quoted printable before it 
hits the desktop. I'm suspect of this service.

- rhp
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

18 years ago
Nope.  You're right that I had my mozilla pref set for quoted-printable, whereas
my 4.x pref was set to as-is.  So I changed the mozilla pref, and tried again to
send to the same user.  He still sees the error message, and the headers now no
longer include the line about autoconversion.  Note that I send mail to this
user all the time with 4.x, and it works fine.  I expect mozilla mail to be able
to send to any user I could converse with with Netscape (otherwise I can't use
mozilla instead of Netscape).
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Reporter)

Comment 4

18 years ago
Rich: you mention testing with Outlook Express, but is it possible that you're
talking about the Windows version?  OE/Mac is a completely different program,
very popular among Mac users.

Comment 5

18 years ago
Sorry, but I can't debug without the source to the message as your friend is 
receiving it. The problem is that we are adhearing to the standard. If OE on 
Mac isn't smart enough to deal with it, there is little I can do.

- rhp
Status: REOPENED → ASSIGNED
(Reporter)

Comment 6

18 years ago
What level of source do you need to see?  My friend thought that the headers
would tell us what we need to know (remember, this is a plaintext message, so
there's no html source or mime multipart headers to deal with).  Let me know
what you need, and I'll ask for it ...

Comment 7

18 years ago
So is the bug that we're sending QP when we shouldn't? Or than the QP we 
generate is wrong? Seems like this should be easy enough to verify, given the 
body of the message that their QP -> 8bit translator started with. Or some other  
message which demonstrates the problem, if you (Akkana) prefer.

Comment 8

18 years ago
My uneducated guess is that OE on Mac is barfing on valid (but not common) 
format=flowed/quoted printable messages. I've asked for the source of the 
message from the person on the mac to verify.

- rhp
(Reporter)

Comment 9

18 years ago
It's not just quoted printable; this happened after I switched my pref to "send
as is".  I'm not sure what's triggering the problem.  I'll append message source
as soon as I get some.
(Reporter)

Comment 10

18 years ago
Created attachment 6386 [details]
A message which caused the complaint
(Reporter)

Comment 11

18 years ago
Re my last comment: it looks like our mail server translated my message to
quoted-printable even though I didn't send it that way.  ??

In looking at the headers from these various messages, I notice that some say
8bit and some say 7bit, though I never use any characters beyond 7-bit ascii
when I'm typing the message.  I haven't found any regularity to which messages
say 8 vs 7 bits, or between the number of bits and whether the message will
cause OE/Mac to complain.  Why is it sometimes 7 and sometimes 8, and could this
be relevant to this bug?

Comment 12

18 years ago
Ok...how about this...

Akkana, can you take look in your sent folder and save the copy of the messages 
that were sent. Maybe I can tell from the original copies what is going on. 
There is no reason we should be sending 8-bit unless we really need to.

- rhp

Comment 13

18 years ago
Hi Akkana,
Let me know if you can dig those messages up from your Sent folder and I will 
take a look at them.

- rhp
Target Milestone: M18
(Reporter)

Comment 14

18 years ago
Created attachment 6527 [details]
the message from my sent folder
(Reporter)

Comment 15

18 years ago
Sorry, forgot to do that yesterday.  I've attached the message from my Sent
folder.  Any idea what's up with all the newlines between the headers of the
forwarded message?

Updated

18 years ago
Target Milestone: M18 → M19

Comment 16

18 years ago
Hi Akkana,
Any idea if this problem is still showing up. Not sure I'll be able to do much 
with this one.

- rhp
Target Milestone: M19 → Future

Comment 17

18 years ago
I am using OE 5.01 and just used Perl to send myself the attachment, and 
there was no error message for me.

Comment 18

17 years ago
reassigning to ducarroz
Assignee: rhp → ducarroz
Status: ASSIGNED → NEW

Updated

17 years ago
Status: NEW → ASSIGNED
Whiteboard: outlook
Product: MailNews → Core

Updated

10 years ago
Assignee: ducarroz → nobody
Status: ASSIGNED → NEW
QA Contact: lchiang → composition
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.