incorrect error shown if can't write to profile directory on startup

VERIFIED DUPLICATE of bug 278860

Status

--
minor
VERIFIED DUPLICATE of bug 278860
13 years ago
12 years ago

People

(Reporter: erictrue, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla Thunderbird 1.0.7 (Windows/20050923)

error message: 'Profile In Use -- Mozilla Thunderbird cannot use the profile
"Foo" because it is in use. Please choose another profile or create a new one.'
This is shown when disk is full, invalid path in profile.ini; possibly any
condition where  parent.lock can't be written to.

Reproducible: Always

Steps to Reproduce:
1. Rename your profile directory (e.g., zc6lso9q.default_hide_me)
2. Start Thunderbird. (The "choose user profile" window will appear, even if
StartWithLastProfile=1.)
3. Select the profile (which you renamed above) and click "Start Thunderbird."
Actual Results:  
Dialog shown: 'Profile In Use -- Mozilla Thunderbird cannot use the profile
"Foo" because it is in use. Please choose another profile or create a new one.'

Expected Results:  
Should have attempted to determine cause of error, and let the user know if
there's anything they can do to resolve it. For example, many users understand a
message like "Please free some disk space and try again."
The other conditions might be harder for the average user to deal with, but for
troubleshooting purposes you might try:
"Profile directory does not exist."
"Directory not writeable; we have no idea why anyone would do this to you.
Please contact your sysadmin."

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 278860 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.