New event date at details is not correct and invalid date, and crashes

RESOLVED DUPLICATE of bug 307895

Status

Calendar
Internal Components
--
critical
RESOLVED DUPLICATE of bug 307895
13 years ago
13 years ago

People

(Reporter: nac, Assigned: shaver)

Tracking

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ja-JP; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051017 Mozilla Sunbird/0.2+

"New Event" window has incorrect date like "2005/10/2005".

once click the select button of "from date"(calendar of this mounth is
displayed), and next, click the select button of "from time", then it turns
"Invalid date".

In that situation, if I click the "OK" button, then an event on Epoch is
displayed. When I select that epoch event sunbird crash.

Reproducible: Always

Steps to Reproduce:
1.click "from date" select button in "New Event" window.
2.click "from time" select button in "New Event" window.
3.displayed strings turns "Invalid date".
4.Click OK button.
5.an strange entry is displayed.
6.select the entry, and sunbird crashes


Actual Results:  
an strange entry(its start date is Epoch) remains.
The way to solve is delete Profile Directory or sotrage.sdb 


this is dump of Epoch entyr from storage.sdb.

sqlite> select * from cal_events;
0|uuid:1129648854687|1129648267000000|1129648854000000|test|0||NONE|||4|-1000000|floating|-1000000|f
loating|||


I use sunbird in Asia/Tokyo timezone.

Comment 1

13 years ago
Please retest with 2005-10-18 build. Bug 307895 "Date.toLocalFormat("%x") with 
format yyyy/MM/dd produces yyyy/MM/yyyy" was fixed with this build.

Comment 2

13 years ago

*** This bug has been marked as a duplicate of 307895 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.