Throbber doesn't stop, busy mouse cursor with document.write

VERIFIED DUPLICATE of bug 81980

Status

()

defect
--
major
VERIFIED DUPLICATE of bug 81980
14 years ago
14 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
20051017 trunk FF

Not sure which component the actual bug lies in, but I'll start with the most
obvious place (JS).

Any document.write() causes the throbber to spin and the mouse to have a busy
cursor forever (or until you push "Stop").

This makes it appear like Firefox is malfunctioning on pages that use
document.write().
(Reporter)

Comment 1

14 years ago
Just open the testcase to see.
Why is JS the most obvious place? Core: JS Engine is for bugs in the JavaScript
engine itself. Just because the bug occurs because of a JavaScript statement
doesn't mean it's a JS engine bug. You should file in Firefox: General if you
aren't sure.

*** This bug has been marked as a duplicate of 81980 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

14 years ago
It doesn't matter. When I file bugs in Firefox:General you bitch too. See Bug
309062. It would probably be more helpful for the process in general if you
didn't contradict yourself (especially when chastizing people).
(In reply to comment #3)
> It doesn't matter. When I file bugs in Firefox:General you bitch too. See Bug
> 309062. It would probably be more helpful for the process in general if you
> didn't contradict yourself (especially when chastizing people).

I only asked why you filed it in General because you file bugs as NEW. If you're
not sure whether a bug is a bug, or what component it belongs in, you should be
filing bugs as UNCONFIRMED.
(Reporter)

Comment 5

14 years ago
That would be a good bug to file against Bugzilla since that is the default
state of new bugs, and I don't change fields unless they need to be. I figure
they set it as default for a reason.
(Reporter)

Comment 6

14 years ago
I want to be sure: You are saying that even when I have no doubt whatsoever that
a bug is in fact a bug, but I do not know for absolute certainty from which
component the error originates, that it should be filed as unconfirmed?

So, for example, if I have a compose window that I can't type in, I shouldn't
file that under Thunderbird:Composition Window, but file it as
Thunderbird:General and set the initial state to unconfirmed until I rule out
all other possibilities for characters not appearing when typing in a compose
window? I mean it could be that the letters are being accepted and they're just
white, or that the focus isn't correct, etc.

Anyway, I can't find any of this over at
https://bugzilla.mozilla.org/page.cgi?id=bug-writing.html. Perhaps I missed it
somewhere?

Updated

14 years ago
Status: RESOLVED → VERIFIED
(In reply to comment #6)
> I want to be sure: You are saying that even when I have no doubt whatsoever that
> a bug is in fact a bug, but I do not know for absolute certainty from which
> component the error originates, that it should be filed as unconfirmed?

I'm not asking for absolute certainty, far from it. I'm asking that you have a
basic understanding of the Products and Components before filing a bug as NEW.
If you don't, then you should be filing unconfirmed bugs, so that someone who
does have that understanding can triage it.

You should look for a duplicate, first and foremost. Then, if you've confirmed
that it is not a duplicate, you should determine which component to file it in.
If you do now know which component to file it in, you should probably ask
someone who does.

> So, for example, if I have a compose window that I can't type in, I shouldn't
> file that under Thunderbird:Composition Window, but file it as
> Thunderbird:General and set the initial state to unconfirmed until I rule out
> all other possibilities for characters not appearing when typing in a compose
> window?

Until you've confirmed that the problem is in Thunderbird's implementation of
the composition window, by testing or code inspection, you should not file a NEW
bug in Thunderbird:Composition Window. If you have problems with Thunderbird's
Composition window, and are not sure of the cause or breadth of that problem,
you should file an unconfirmed bug in Thunderbird:Composition Window.

> Anyway, I can't find any of this over at
> https://bugzilla.mozilla.org/page.cgi?id=bug-writing.html. Perhaps I missed it
> somewhere?

On that page, I see:
"Not sure which to choose? Click on the Component link. You'll see a description
of each component, to help you make the best choice."

The description for Core: Javascript Engine contains:
"The interpreter engine for the core JavaScript language, independent of the
Mozilla browser and its object model."
and:
"File ONLY core JavaScript language bugs in this category; file DOM, style bugs
to the DOM Level 0 component."

Again, all I'm saying is that if you are unsure of which product to file in, ask
someone who isn't, or file unconfirmed so that the bug can be appropriately triaged.
You need to log in before you can comment on or make changes to this bug.