After re-login on windows, main window is repainted wrongly.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
11 years ago

People

(Reporter: lucky, Unassigned)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

I have a WinXp SP2 system with multi users. If I start Firefox, and then e.g.
someone else in the family switches users to use their account, when I switch
back, my Firefox window is not being painted correctly. It's like the top level
container is not painting it's children in the right place. See the attached
screenshot:

You can see there is a blank area above the toolbar. Also, the right hand edge
of the window overlaps the scroll bar and the Close Tab button. If I expand the
window right, the tabs will be stretched to fit, but if I try to make the window
more narrow, the right hand edge overlaps the tabs until none are visible.


Reproducible: Sometimes

Steps to Reproduce:
1. Start firefox. Open up a bunch of tabs
2. Switch user in WinXp. 
3. After some time, log back in as original user
4. Select Firefox window. You'll see the container is not painted correctly.

Actual Results:  
See screenshot to follow

Expected Results:  
Painted the UI correctly.


This is the list of my plugins:

All-in-one Sidebar: 0.5.4
Cutemenus: 0.6.2
Download manager tweak: 0.6.6
Download status bar: 0.9.3.1
Ebay Negs: 0.6
Forecastfox: 0.8.2.3
Gmail notifier: 0.5.2.1
Google toolbar: 1.0.20051012
Googlepreview: 1.0.3
IE View: 1.2.6.1
Popupsound: 0.1.3
ReloadEvery: 0.6.1
Tab mix: 0.2
Tabbrowser Prefs: 1.2.8.5

I am using the Qute theme, version 3.
(Reporter)

Comment 1

13 years ago
Created attachment 199957 [details]
Screenshot
(Reporter)

Comment 2

13 years ago
Further to this bug. I have realized that it does not happen after just any login, but rather if someone else has logged in to their user on a multi user windows machine. I.e.

- User A logs in, opens firefox. Has more than one tab.
- User B then logs in (or Switch(es) User) and opens firefox
- User A then logs in again.

The weird container problem show itself.

I am also raising the severity of this bug since it happens all the time, on multiple machines. It requires a complete restart of the browser to remove the problem. 
Severity: normal → major
Summary: After re-login on windows, main window is repainted wrongly. → After re-login on windows, main window is repainted wrongly.
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Severity: major → normal
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.0 Branch
(Reporter)

Comment 4

11 years ago
I just did a test and did not see this bug. I guess it was fixed somewhere along the way. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.