Outdated password appears

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
10 years ago

People

(Reporter: fatz2fly, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

I changed my password on eBay.  However, the old password keeps appearing, even
after I cleared all saved password information and cleared all saved form
information.  I then uninstalled firefox and later reinstalled it.  The old
password still appears.

Reproducible: Always

Steps to Reproduce:
1.Cleared all saved forms and saved passwords;
2.Then logged on to eBay with new password
3.Checked box to save new password
3.Logged off eBay and closed firefox

Actual Results:  
The next time I opened firefox and then logged onto eBay, the logon page had
already typed my old password.

Expected Results:  
Firefox should have remembered the new password.
Component: Form Manager → Password Manager
QA Contact: form.manager → password.manager
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051018
Firefox/1.4.1 ID:2005101816

This looks like Bug 279596 (although I changed passwords multiple times and
never saw this problem).
FYI, if you delete the files signons.txt and key3.db in your profile, your
passwords will definitely be gone.
http://kb.mozillazine.org/Profile_Folder
This is mostly likely a dupe of the bug mentioned in the last comment (or otherwise fixed by now). If you can still reproduce on a current Firefox release with a clean profile, please reopen with the steps needed to reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE

Comment 3

11 years ago
I once again uninstalled Firefox 2.0.0.4.  I deleted signons.txt and key3.db files.  I also deleted all cookies and temporary internet files from the website where I am experiencing the problem (www.usta.com - United States Tennis Assoc).  I reinstalled Firefox 2.0.0.4 after a complete system shutdown.  I went back to the website, and the old information is still saved in the password and text boxes.  Also, new passwords and new autocomplete text information is only saved until I shut down the open Firefox session.
I am positive this is not a glitch associated with the website, as I access this same website using Firefox 2.0.0.4 from two other systems.  Old data on both these two systems can be deleted and new information added without problems.
Is there anything else I can try?  I use this site three to four times per day.
Did you delete both signons.txt and signons2.txt, if they existed?

To test with a clean profile, use the profile manager to create a new profile. http://kb.mozillazine.org/Profile_Manager

The only thing in Firefox that should be filling in a password field is the password mananger, which only stores passwords in signons2.txt. If you're still seeing something being filled in, you either didn't delete the right signons[2].txt file, or you have an extension or something that's doing this.

Where on usta.com are you logging in at? I didn't see any obvious place to provide a username/password.

Comment 5

11 years ago
I did delete signons.txt & signons2.txt, as well as key3.db, all to no avail. The old password and form data remained on this particular site. I finally uninstalled Firefox again and then deleted all Mozilla files and folders.  After a cold shutdown, I reinstalled Firefox and the problem is now resolved.  
The actual link I was having the problem with is http://tennislink.usta.com/leagues/.  I don't think the site has anything to do with the problem, because I access this same site using two other systems and never had this problem. I was always able to delete old password and form data without incident on the other two systems.
If the problem crops up again, I will post a new incident.
Hmm, strange. You were deleting the right files, so whatever was going on probably wasn't caused by the password manager. If you run into this again, please reopen!
Resolution: INCOMPLETE → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.