Title RSS bug-list based on Saved Search name

RESOLVED FIXED in Bugzilla 2.22

Status

()

Bugzilla
Query/Bug List
--
trivial
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Albert Ting, Assigned: Frédéric Buclin)

Tracking

2.21
Bugzilla 2.22
Bug Flags:
approval +

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

All the RSS bug-list feeds hardcodes the title to "Bugzilla Bugs".  This
prevents me from migrating all my saved-queries into RSS feeds, for they will
all say "Bugzilla Bugs".  I'm not familiar enough with RSS to know the right way
to fix it, but I think taking advantage of query_based_on URL token would work. 

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

12 years ago
Created attachment 200004 [details] [diff] [review]
suggested patch

Enclosed is my suggestion. I just added the defaultsavename as part of the
title. 
I know the saved name does not necessarily equate to the saved query, nor will
it work if the query wasn't from a saved query.  But it's better than nothing!
:)

Updated

12 years ago
Assignee: query-and-buglist → altlst
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Have a more detailed title for RSS bug-list feeds → Ttitle RSS bug-list based on Saved Search name
Version: unspecified → 2.21
(Assignee)

Updated

12 years ago
Summary: Ttitle RSS bug-list based on Saved Search name → Title RSS bug-list based on Saved Search name
(Assignee)

Comment 2

12 years ago
Created attachment 202384 [details] [diff] [review]
patch, v1

I couldn't find an easier way of doing this, so I added the param 'title' when the extension is "rss". 'query_based_on' is filtered by buglist.cgi and 'namedcmd' is only used when running a saved search.
Assignee: altlst → LpSolit
Attachment #200004 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #202384 - Flags: review?(myk)
(Assignee)

Updated

12 years ago
Target Milestone: --- → Bugzilla 2.24
Comment on attachment 202384 [details] [diff] [review]
patch, v1

>Index: buglist.cgi

>+    # The title of the RSS feed will be the same one as for the bug list.
>+    $vars->{'title'} = $cgi->param('title');

This is a great reuse of the already generated title, because it means the RSS feed title will also get updated if we ever improve the HTML version's title.

r=myk
Attachment #202384 - Flags: review?(myk) → review+
(Assignee)

Updated

12 years ago
Flags: approval?
Low-risk polish fix. Suitable for checkin during release freeze.
Severity: enhancement → trivial
Flags: approval? → approval+
Target Milestone: Bugzilla 2.24 → Bugzilla 2.22
(Assignee)

Comment 5

12 years ago
Checking in buglist.cgi;
/cvsroot/mozilla/webtools/bugzilla/buglist.cgi,v  <--  buglist.cgi
new revision: 1.320; previous revision: 1.319
done
Checking in template/en/default/list/list.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/list/list.html.tmpl,v  <--  list.html.tmpl
new revision: 1.43; previous revision: 1.42
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.