If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

when changing an extensions id (both extensions still installed) uninstalling the old extension doesn't exclude it from checking for updates

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: Henrik Gemal, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
I just uninstalled an extension (didn't restart) and when I clicked the check
for updates the extension which before said "will be uninstalled when restart"
now says "there's an update available"

when you uninstall an extension the extension should be marked as "dont check
for updates" untill the user restarts firefox
I just checked with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5)
Gecko/20051018 Firefox/1.4.1 ID:2005101805 and extensions that will be
uninstalled on restart weren't checked. I fixed that a while ago and unless it
regressed it shouldn't be checking. What build are you using?
(Reporter)

Comment 2

12 years ago
ok found my problem. the situation is a bit strange.

I have two version of the slashy extension installed. The slashy extension
changed GUID between two versions.

So I uninstalled the old slashy (didn't restart) and pressed the update button

now firefox checkes for updates but it checked both the old slashy (the
uninstalled) and the new slashy and mark the old slashy as having an update.

Not sure if this can be fixed or it's a wontfix
Nothing comes to mind that would cause this to happen under those circumstances
but if you provide test xpi's along with steps to reproduce then the underlying
cause could be looked into.
any luck with reproducing this and providing xpi's along with steps to reproduce?
Summary: uninstalling extensions doesn't exclude it from checking for updates → when changing an extensions id (both extensions still installed) uninstalling the old extension doesn't exclude it from checking for updates
(Reporter)

Comment 5

12 years ago
(In reply to comment #4)
> any luck with reproducing this and providing xpi's along with steps to
> reproduce?
> 

nope. not yet. I'll try some more
I am still unable to reproduce. I'd be interested in where the code is failing for this even though it is an edge case but steps to reproduce that work, etc. are needed to take this bug any further. :(
Henrik - I've tried reproducing this bug several times without being able to do so... are you ok with resolving it wfm?
(Reporter)

Comment 8

12 years ago
I was once able to reproduce but not since. Something might have changed.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.