Last Comment Bug 312994 - new SeaMonkey artwork
: new SeaMonkey artwork
Status: RESOLVED FIXED
: fixed1.8
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All All
: -- normal (vote)
: seamonkey1.0beta
Assigned To: Robert Kaiser (not working on stability any more)
:
Mentors:
: 239522 (view as bug list)
Depends on:
Blocks: 308866 318986 321927 441061
  Show dependency treegraph
 
Reported: 2005-10-19 04:44 PDT by Robert Kaiser (not working on stability any more)
Modified: 2008-06-21 15:31 PDT (History)
13 users (show)
kairo: blocking‑seamonkey1.0b+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch to code files (Makefile/themes) (3.70 KB, patch)
2005-12-01 07:54 PST, Robert Kaiser (not working on stability any more)
neil: review+
neil: superreview+
Details | Diff | Review
list of files touched by the logo change (1.36 KB, text/plain)
2005-12-01 07:57 PST, Robert Kaiser (not working on stability any more)
no flags Details

Description Robert Kaiser (not working on stability any more) 2005-10-19 04:44:21 PDT
After we have a final decision on a SeaMonkey logo, we need to make up all
needed artwork derived from it and get that into the tree.

This is needed for trunk and SeaMonkey 1.0 Beta (1.8 branch).
Comment 1 Robert Kaiser (not working on stability any more) 2005-11-18 16:58:13 PST
It may be a good idea to roll in something along the lines of bug 262265 with this as well, as it's just shipping an additional version of the icon...
Comment 2 Eyal Rozenberg 2005-11-24 14:07:47 PST
*** Bug 239522 has been marked as a duplicate of this bug. ***
Comment 3 Robert Kaiser (not working on stability any more) 2005-12-01 07:54:31 PST
Created attachment 204690 [details] [diff] [review]
patch to code files (Makefile/themes)

This patch has all changes need to non-image files in the SeaMonkey codebase: Mainly, those are changes to make themes look nice with our new rounded throbber image - and the Makefile change fixes bug 262265 on our side along the way.
Comment 4 Robert Kaiser (not working on stability any more) 2005-12-01 07:57:49 PST
Created attachment 204691 [details]
list of files touched by the logo change

This second attachment is a full list of files that get touched by this logo change. I won't attach the images themselves, they get signed off by the SeaMonkey Council.
Comment 5 neil@parkwaycc.co.uk 2005-12-01 08:34:14 PST
Comment on attachment 204690 [details] [diff] [review]
patch to code files (Makefile/themes)

> #navigator-throbber:hover:active {
>-  -moz-border-top-colors: ThreeDDarkShadow ThreeDShadow;
>-  -moz-border-right-colors: ThreeDDarkShadow ThreeDHighlight;
>-  -moz-border-bottom-colors: ThreeDDarkShadow ThreeDHighlight;
>-  -moz-border-left-colors: ThreeDDarkShadow ThreeDShadow;
> }
Nit: just remove the entire block.
Comment 6 Robert Kaiser (not working on stability any more) 2005-12-02 12:58:19 PST
Comment on attachment 204690 [details] [diff] [review]
patch to code files (Makefile/themes)

The new SeaMonkey artwork has landed on trunk and web pages! \o/

Requesting approval for checking in this patch along with the images (see other attachment in this bug) into 1.8 branch for SeaMonkey 1.0 (beta).
Comment 7 Eyal Rozenberg 2005-12-04 05:39:47 PST
Nitpick regarding the splash-screen: IMHO It should "An Internet application suite", not "all-in-one" internet application suite. It's not as though it's an SSH client, or an IM application, etc.
Comment 8 Jason Bassford 2005-12-04 06:23:12 PST
Actually, I disagree. I like the current splash screen slogan.  I don't think that "Internet application" says anything different.  Also, when I hear "application" in this context I think of some wound being treated medically - or of a washing machine (too close to "appliance").

Then again, to be fair, "all-in-one", if I think about it, reminds me a bit of those Benylin ads - so who knows? <grin>

However - I'm not sure if the disussion of the wording of the splash screen should be dealt with in this particular bug...
Comment 9 Robert Kaiser (not working on stability any more) 2005-12-05 05:24:05 PST
Comment on attachment 204690 [details] [diff] [review]
patch to code files (Makefile/themes)

Clear approval flag. This will go into branch today, once I get an improved mac .icns file :)
Comment 10 Robert Kaiser (not working on stability any more) 2005-12-05 11:21:41 PST
Checked into branch as well (cleared to land by mtschrep in email to
seamonkey-council), and additionally fixed the mac .icns file to look even better.

If you're on Windows, make sure you force the system to clear/rebuild its icon cache, or it might still show the placeholder icon, see bug 318953

Note that we only replaced graphics that had the placeholder artwork, stuff like modern theme's component bar (bug 318986) or the component icons are known to still carry the "m" (at least in big enough versions) and will be fixed later. The navigator wheel is no bug for itself btw where it appears... The browser component is still associated with the "navigator" name, we're not yet sure if we'll leave the wheel there or replace it one day.
Comment 11 Robert Kaiser (not working on stability any more) 2005-12-08 05:23:28 PST
I forgot to change mozilla/xpinstall/wizard/unix/src2/logo.xpm in that checkin, this has been done now as well.
Comment 12 Worcester12345 2005-12-08 09:23:39 PST
(In reply to comment #8)
> Actually, I disagree. I like the current splash screen slogan.  I don't think
> that "Internet application" says anything different.  Also, when I hear
> "application" in this context I think of some wound being treated medically -
> or of a washing machine (too close to "appliance").
...
> However - I'm not sure if the disussion of the wording of the splash screen
> should be dealt with in this particular bug...

Since you did, I think "program" is more understood than "application". If this is to have a go in the business world, go with "program" or "Internet Program" to be specific. Bosses don't want to have to ponder this, and nobody wants to explain "application" or "suite" to a boss or other workers. "Seamonkey" is a whole other matter, and I'd rather just use IE than try to say it with a straight face.

Comment 13 Andrew Schultz 2006-02-04 12:50:51 PST
*** Bug 239522 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.