Enhancement for browsing pages with frames

RESOLVED FIXED

Status

Minimo
Minimo Front-End
--
enhancement
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: Richard Stewart, Assigned: dougt)

Tracking

WinCE
Other
Other

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051003 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows CE 4.21; rv:19a1) Geco/20050921 Minimo/0.009

In Pocket IE (If I can remember correctly) if the page has frames, you can
resize them with the stylus to enable you to read text that may be obscured
because of the small screen size. It would be really nice to be able to do this
in Minimo too. Enabling frame resizing by dragging the boarders makes some sites
with frames useable that wouldn't be otherwise. 

Reproducible: Always

Steps to Reproduce:
Use a site with frames
Actual Results:  
Often hard to navigate, with complicated scrolling of indervidual frames

Expected Results:  
Let you resize the frames, to let you decide the best proportions for the small
screen.
(Reporter)

Comment 1

13 years ago
I've been looking around and have found that firefox enables this with a simple pref which can be accessed from about:config or by adding the following: fireuser_pref("layout.frames.force_resizability", true);
To user.js

As they are both based on Geco, I assume this setting is buried in Minimo too. It would be nice to have the about:config feature in Minimo, and I will make a feature request for it.
(Assignee)

Comment 2

13 years ago
richard,

does setting pref("layout.frames.force_resizability", true); work better for you wrt frames?

about:config does work in recent releases.
(Reporter)

Comment 3

13 years ago
I've done a reinstall and now I can access about:config the setting I requested seems to be the default. Either it has been changed in recent releases or my issue was a site spcific problem which I'm unable to verifiy.

Anyway, if you can confirm the default is pref("layout.frames.force_resizability", true); then this is best so this can be resolved.

Thanks

Rich :o)
(Assignee)

Comment 4

12 years ago
*** Bug 332304 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 5

12 years ago
I added "open this frame in a new tab".  I also made resizing a bit better.  
Please verify in the 0.015 release.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.