CSS "display: none" does not work on the root element

RESOLVED DUPLICATE of bug 283686

Status

()

Core
CSS Parsing and Computation
--
minor
RESOLVED DUPLICATE of bug 283686
13 years ago
13 years ago

People

(Reporter: Ng Ming Hong, Assigned: dbaron)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

332 bytes, text/html
Details
448 bytes, application/xhtml+xml
Details
297 bytes, application/vnd.mozilla.xul+xml
Details
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

The display property of the root element (e.g. html of HTML, window of XUL)
seems to be ignored. Try something like html {display: none} and :root {display:
none}. Other values like inline, table, etc are hard to test, but I guess they
do not work anyway.

Both IE and Opera shows nothing, according to the CSS.

Reproducible: Always

Steps to Reproduce:
1. See test cases

Actual Results:  
The document content is rendered.

Expected Results:  
The document content should not be rendered.
(Reporter)

Comment 1

13 years ago
Created attachment 200087 [details]
HTML test case
(Reporter)

Comment 2

13 years ago
Created attachment 200088 [details]
XHTML test case
(Reporter)

Comment 3

13 years ago
Created attachment 200090 [details]
XUL test case

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 283686 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.