Last Comment Bug 313020 - Implement the ability to add individual bugs to saved searches
: Implement the ability to add individual bugs to saved searches
Status: RESOLVED FIXED
:
Product: Bugzilla
Classification: Server Software
Component: Query/Bug List (show other bugs)
: 2.21
: All All
: -- enhancement (vote)
: Bugzilla 2.22
Assigned To: Frédéric Buclin
: default-qa
Mentors:
: 361899 (view as bug list)
Depends on:
Blocks: 95722 344435
  Show dependency treegraph
 
Reported: 2005-10-19 09:24 PDT by Frédéric Buclin
Modified: 2006-11-26 14:07 PST (History)
4 users (show)
justdave: approval+
LpSolit: documentation+
LpSolit: documentation2.22+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch, v1 (10.48 KB, patch)
2005-10-19 12:27 PDT, Frédéric Buclin
no flags Details | Diff | Splinter Review
patch, v1.1 (10.78 KB, patch)
2005-10-19 15:36 PDT, Frédéric Buclin
bugreport: review-
Details | Diff | Splinter Review
patch, v2 (13.37 KB, patch)
2005-10-21 07:28 PDT, Frédéric Buclin
bugreport: review+
Details | Diff | Splinter Review
docs patch v1 (1.07 KB, patch)
2006-01-08 06:28 PST, victory <never@receive.bug.mails.i.hate.spammer>
timeless: review-
Details | Diff | Splinter Review
docs patch for tip v2 (1.02 KB, patch)
2006-02-14 15:58 PST, victory <never@receive.bug.mails.i.hate.spammer>
mozilla+bmo: review-
Details | Diff | Splinter Review
docs patch for tip v3 (1.76 KB, patch)
2006-05-28 06:15 PDT, victory <never@receive.bug.mails.i.hate.spammer>
mozilla+bmo: review-
Details | Diff | Splinter Review
docs patch for tip v4 (1.88 KB, patch)
2006-05-28 09:20 PDT, victory <never@receive.bug.mails.i.hate.spammer>
goobix: review-
Details | Diff | Splinter Review
documentation patch, v5 (9.61 KB, patch)
2006-11-23 12:37 PST, Frédéric Buclin
no flags Details | Diff | Splinter Review
documentation patch, v5.1 (9.62 KB, patch)
2006-11-23 12:40 PST, Frédéric Buclin
no flags Details | Diff | Splinter Review
documentation patch, v5.2 (9.69 KB, patch)
2006-11-23 13:29 PST, Frédéric Buclin
mozilla+bmo: review+
Details | Diff | Splinter Review

Description Frédéric Buclin 2005-10-19 09:24:21 PDT
The footer should allow you to add individual bugs to existing or new saved
searches, for instance using a UI similar to
http://landfill.bugzilla.org/qa220rc2/attachment.cgi?id=347

These saved searches would have a special status (i.e. needs a new column in the
namedqueries table) to only accept a list of bug IDs. Of course, the drop-down
menu would only shows these saved searches.

They can then be used as normal saved searches, for instance for whining and can
also be edited.
Comment 1 Frédéric Buclin 2005-10-19 12:27:34 PDT
Created attachment 200123 [details] [diff] [review]
patch, v1
Comment 2 Frédéric Buclin 2005-10-19 15:36:28 PDT
Created attachment 200149 [details] [diff] [review]
patch, v1.1

minor update to prevent a crash when no query name is given
Comment 3 Joel Peshkin 2005-10-21 05:39:41 PDT
Comment on attachment 200149 [details] [diff] [review]
patch, v1.1


cool

nit....
>+            $new_query = "bug_id=" . join(',', keys %bug_ids);
May as well sort the list.  This should make it easier to manage when loading
one of these searches into "edit this search"

I dont think this wants to be required on every user's footer.	Please add a
user pref for the footer display.  Also factor it out into a distinct template
file that is called by Useful-links.html.tmpl if the user pref is enabled. 
That will make it merge with other skins much more easily.

There are a whole bunch of RFEs I have for this, but they can be additional
bugs. 
The first of those is I would like to have buglists displayed with checkboxes
like the change-multiple form to add/remove bugs from the saved queries.
Comment 4 Frédéric Buclin 2005-10-21 07:28:17 PDT
Created attachment 200343 [details] [diff] [review]
patch, v2

- bug IDs sorted before being stored;
- separate global/per-bug-queries.html.tmpl template;
- 'per-bug-queries' user pref added to enable/disable this feature.
Comment 5 Olav Vitters 2005-10-21 15:11:27 PDT
Bug 95722 seems to be a dupe of this one (read the description, not the summary).
Comment 6 Frédéric Buclin 2005-10-23 11:18:14 PDT
Not exactly a dupe as the goal of my patch is to be able to add individual bugs to some given list of bugs, independently of any query result. Bug 95722 is the next step in the process, i.e. to be able to add some selected bug IDs from a bug list.
Comment 7 Joel Peshkin 2005-10-23 11:27:50 PDT
Comment on attachment 200343 [details] [diff] [review]
patch, v2

The more I play with this, the more RFEs I have.  Let's start with this and start down the RFE path.
Comment 8 Joel Peshkin 2005-10-23 11:29:33 PDT
Comment on attachment 200343 [details] [diff] [review]
patch, v2

One nit (on checkin)...

Please check for the user pref in useful links before calling the template that makes the form.  That way, it can be called from elsewhere (like saved searches) even if the pref for the footer is off.
Comment 9 Frédéric Buclin 2005-10-23 11:38:08 PDT
Why this request? If the param is off, I see no reason to display it in some pages.
Comment 10 Dave Miller [:justdave] (justdave@bugzilla.org) 2005-10-24 20:09:27 PDT
(In reply to comment #7)
> (From update of attachment 200343 [details] [diff] [review] [edit])
> The more I play with this, the more RFEs I have.  Let's start with this and
> start down the RFE path.

hear hear!  (and hence my approval anyway, despite the reservations I had on IRC, as we can work on preference wording later)
Comment 11 Frédéric Buclin 2005-10-25 10:55:55 PDT
Checking in buglist.cgi;
/cvsroot/mozilla/webtools/bugzilla/buglist.cgi,v  <--  buglist.cgi
new revision: 1.315; previous revision: 1.314
done
Checking in checksetup.pl;
/cvsroot/mozilla/webtools/bugzilla/checksetup.pl,v  <--  checksetup.pl
new revision: 1.445; previous revision: 1.444
done
Checking in Bugzilla/Constants.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/Constants.pm,v  <--  Constants.pm
new revision: 1.29; previous revision: 1.28
done
Checking in Bugzilla/User.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/User.pm,v  <--  User.pm
new revision: 1.92; previous revision: 1.91
done
Checking in Bugzilla/DB/Schema.pm;
/cvsroot/mozilla/webtools/bugzilla/Bugzilla/DB/Schema.pm,v  <--  Schema.pm
new revision: 1.41; previous revision: 1.40
done
Checking in skins/standard/global.css;
/cvsroot/mozilla/webtools/bugzilla/skins/standard/global.css,v  <--  global.css
new revision: 1.16; previous revision: 1.15
done
RCS file: /cvsroot/mozilla/webtools/bugzilla/template/en/default/global/per-bug-queries.html.tmpl,v
done
Checking in template/en/default/global/per-bug-queries.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/per-bug-queries.html.tmpl,v  <--  per-bug-queries.html.tmpl
initial revision: 1.1
done
Checking in template/en/default/global/setting-descs.none.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/setting-descs.none.tmpl,v  <--  setting-descs.none.tmpl
new revision: 1.6; previous revision: 1.5
done
Checking in template/en/default/global/useful-links.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/useful-links.html.tmpl,v  <--  useful-links.html.tmpl
new revision: 1.43; previous revision: 1.42
done
Checking in template/en/default/global/user-error.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/user-error.html.tmpl,v  <--  user-error.html.tmpl
new revision: 1.139; previous revision: 1.138
done
Comment 12 victory <never@receive.bug.mails.i.hate.spammer> 2006-01-08 06:28:08 PST
Created attachment 207895 [details] [diff] [review]
docs patch v1
Comment 13 Max Kanat-Alexander 2006-02-12 17:43:17 PST
Added to the Bugzilla 2.22 Release Notes in bug 322960.

I think this should be "off" by default, in the preferences. We'll see, though, how people react.
Comment 14 timeless 2006-02-14 13:28:47 PST
Comment on attachment 207895 [details] [diff] [review]
docs patch v1

> On the bug list page, you'll see 'Remember search' button,

you'll see _a_

> and subsequently text box.

subsequently is a nice SAT vocab word, but it's not something one would normally use.

instead "'Remember search' button' followed by a text box."

> You can enter some text and press this button to save this condition

"condition" doesn't match anything until this point, in technical terms, i'd use "query", since i've already said don't use query, how about "search's conditions"

> so you can query the same condition easily.

Don't use "query" :).

"so you can easily search for the same conditions again.

> You can delete this by clicking 'Forget Search' link or on your prefs page. 

You can _later_ delete /it/ /using the/ 'Forget Search' link or on your prefs page. 

-- I don't want to tell people who don't use "clicking" devices to click :)

>  As of Bugzilla 2.21.2, individual bugs can be saved and added as Saved Search.

change "as Saved Search" to "to a Saved Search"

But do you need the As of? isn't the documentation for a specific version, or isn't there some markup that tells the xml parser that we mean 2.21.2+?
Comment 15 victory <never@receive.bug.mails.i.hate.spammer> 2006-02-14 15:58:57 PST
Created attachment 211923 [details] [diff] [review]
docs patch for tip v2

only for tip, for others should not include 
+      <para>
+        As of Bugzilla 2.22, individual bugs can be saved and added
+        to a Saved Search.
+      </para>
Comment 16 Colin Ogilvie [:cso] 2006-02-21 08:49:33 PST
Comment on attachment 211923 [details] [diff] [review]
docs patch for tip v2

>Index: docs/xml/using.xml
>+      <para>
>+        As of Bugzilla 2.22, individual bugs can be saved and added
>+        to a Saved Search.
>+      </para>

I was expecting this to actually include documentation of the feature - like how to use it etc.
Comment 17 victory <never@receive.bug.mails.i.hate.spammer> 2006-05-28 06:15:54 PDT
Created attachment 223599 [details] [diff] [review]
docs patch for tip v3
Comment 18 Colin Ogilvie [:cso] 2006-05-28 08:56:06 PDT
Comment on attachment 223599 [details] [diff] [review]
docs patch for tip v3

Better :)

>Index: docs/xml/using.xml
>+    <section id="savedsearch">
>+      <title>Saved Search</title>
>+      <para>
>+        On the bug list page, you'll see a <quote>Remember search</quote>
>+        button followed by a text box. You can enter some text and press
>+        this button to save this search condition so you can easily
>+        search the same condition again.

search the same condition again -> repeat the search again.

>+ You can later delete it using
>+        the <quote>Forget Search</quote> link or on your prefs page.
>+      </para>

or on your prefs page -> or on the <quote>Saved Searches</quote> section of your Prefs page.

>+      <para>
>+        As of Bugzilla 2.22, individual bugs can be saved and added
>+        to a Saved Search. If your
>+        <quote>Add individual bugs to saved searches</quote> is
>+        <quote>On</quote>, you'll see <quote>Add</quote> button and
>+        followed by the button, 2 text box, and if you have this type
>+        of the Saved Searches, select box will also appear on the footer.
>+        To use this, enter bugs' number or aliases of the bugs in the
>+        first text box, select the Saved Searches or enter the name
>+        of the new Saved Searches in the second text box, and press
>+        <quote>Add</quote> button.

This doesn't make much sense to me... some general comments first:

An admin can disable this facility, so it might not exist.
My "Add individual bugs to saved searches" what?
You'll see *an* Add button
2 text *boxes*

I really don't like the description of where the feature is located and the layout of the feature.

"To use this feature, you should enter either the number or aliases of the bug or bugs you wish to add to a sarch in the first text box. You should then either select the existing Saved Search you wish to add them to in the select box or type the name of a new Saved Search in the second text box and then press the Add button."

>+        Note that you CANNOT add individual bugs to the normal type
>+        of the Saved Searches like default query configured by the
>+        <quote>mybugstemplate</quote> parameter.

"Note that you cannot add individual bugs to Saved Searches created from the results of a query" or something would be better.
Comment 19 victory <never@receive.bug.mails.i.hate.spammer> 2006-05-28 09:20:01 PDT
Created attachment 223609 [details] [diff] [review]
docs patch for tip v4
Comment 20 Vlad Dascalu 2006-06-07 15:02:55 PDT
Comment on attachment 223609 [details] [diff] [review]
docs patch for tip v4

+        aliases of the bug or bugs you wish to add to a sarch in the

s/sarch/search/

+        created from the results of a query

A final period would probably be nice here.
Comment 21 Vlad Dascalu 2006-06-08 12:08:40 PDT
Comment on attachment 223609 [details] [diff] [review]
docs patch for tip v4

you'll see an <quote>Add</quote> button and
+        followed by the button, 2 text boxes, and if you have this type
+        of the Saved Searches, select box will also appear on the footer.

This doesn't make much sense like Colin said. I think part of the problem is throwing too many "and"s in only one sentence. Maybe we should go along the path of breaking this up in 2 sentences or so.

Nits from comment #20 would also be welcomed in a new patch.
Comment 22 Frédéric Buclin 2006-11-23 12:37:08 PST
Created attachment 246427 [details] [diff] [review]
documentation patch, v5
Comment 23 Frédéric Buclin 2006-11-23 12:40:34 PST
Created attachment 246428 [details] [diff] [review]
documentation patch, v5.1

I forgot a </section> in v5
Comment 24 Frédéric Buclin 2006-11-23 13:29:22 PST
Created attachment 246431 [details] [diff] [review]
documentation patch, v5.2

I forgot a <title>foo</title> after a <section>, and I also fixed some nits reported by Colin on IRC.
Comment 25 Frédéric Buclin 2006-11-23 13:47:49 PST
tip:

Checking in docs/xml/using.xml;
/cvsroot/mozilla/webtools/bugzilla/docs/xml/using.xml,v  <--  using.xml
new revision: 1.56; previous revision: 1.55
done

2.22.1:

Checking in docs/xml/using.xml;
/cvsroot/mozilla/webtools/bugzilla/docs/xml/using.xml,v  <--  using.xml
new revision: 1.37.2.14; previous revision: 1.37.2.13
done
Comment 26 Olav Vitters 2006-11-26 14:05:11 PST
*** Bug 361899 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.