If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Javascript error when editing attachments

RESOLVED FIXED in Bugzilla 2.20

Status

()

Bugzilla
Attachments & Requests
P2
minor
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Joel Peshkin, Assigned: Erik Stambaugh)

Tracking

2.21
Bugzilla 2.20
Bug Flags:
approval +
approval2.20 +

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
There is a javascript error after marking a non-IFRAME-able attachment obsolete
and hitting submit.  In certain versions of IE, this creates a pop-up error box.

Error: big has no properties
Source File: https://...../attachment.cgi?id=24619&action=edit
Line: 315
(Assignee)

Comment 1

12 years ago
Created attachment 200157 [details] [diff] [review]
should (?) fix it

I was not able to reproduce the problem, but I can tell what it is.  Someone
who can reproduce it please let me know if this fixes it...
Attachment #200157 - Flags: review?
(Reporter)

Comment 2

12 years ago
Comment on attachment 200157 [details] [diff] [review]
should (?) fix it

yep... that does the trick

To reproduce, watch the javascript console as you edit and attachment that does
not need an IFRAME (like a word doc).  Without commenting (or changing
anything, click SUBMIT).   This will generate an error without this patch.
Attachment #200157 - Flags: review? → review+
(Reporter)

Comment 3

12 years ago
The function in 2.20 is the same.
Status: NEW → ASSIGNED
Flags: approval?
Flags: approval2.20?
Priority: -- → P2
Target Milestone: --- → Bugzilla 2.20
Flags: approval?
Flags: approval2.20?
Flags: approval2.20+
Flags: approval+
(Reporter)

Comment 4

12 years ago
HEAD
Checking in template/en/default/attachment/edit.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/attachment/edit.html.tmpl,v
 <--  edit.html.tmpl
new revision: 1.29; previous revision: 1.28
done

2.20
Checking in template/en/default/attachment/edit.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/attachment/edit.html.tmpl,v
 <--  edit.html.tmpl
new revision: 1.27.4.1; previous revision: 1.27
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
*** Bug 253453 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.