download greater than 2gig shows negative size count after reaching 2 gig

VERIFIED DUPLICATE of bug 228968

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 228968
12 years ago
10 years ago

People

(Reporter: bill, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

This happened while saving onto a fat32 partition from a ntfs boot partition.
Windows appears to report correct file size (2.7 gigs and counting) but the
download manager is reporting a negative file size and negative download rate. i
do not have the bandwidth to try to replicate this problem. it occured while
downloading the ubuntu live/install dvd filename ubuntu-5.10-dvd-i386.iso  from
http://cdimage.ubuntu.com/releases/breezy/release/. It is probably unrelated to
the specific file. The total filesize was listed as unknown for the duration of
download.

Reproducible: Didn't try

Steps to Reproduce:
1.Right click link and choose 'save as' to fat32 partition
2.
3.

Actual Results:  
Started counting normally until sometime after 2 gig had been received then
started counting negatively from 0 at a negative rate. File passes md5sum check
so bug appears to be cosmetic.

Expected Results:  
Continuous positive file size count, possibly with rounding but certainly with
positive rate.

*** This bug has been marked as a duplicate of 228968 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.