broken link after XMLHTTPRequest changed the link

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: DX, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.7.10) Gecko/20050717 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.7.10) Gecko/20050717 Firefox/1.0.6

 When the source file of the div, where the link «lalala» is, is reloaded, the
link gets broken. If the order to reload goes from the main page, there is no
problem. But when it goes from the popup, there is this prob. In the console
javascript an error is reported:

Erro: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMJSWindow.open]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame :: <unknown filename> :: onclick ::
line 0"  data: no]


 This only happens in FireFox: In IE and Opera is working fine.

 Please check the source code of these files:

 » xhr.html
 » xhr_data.html
 » xhr_popup.html
 » xhr_ap.html

 (in «http://srv2.gimmestock.com/xhr/»)

Reproducible: Always

Steps to Reproduce:

0. Go to «http://srv2.gimmestock.com/xhr/xhr.html»
1. Click in «lalala» to open a popup and see that the link is working; than
close the popup;
2. Click in the main page button «Click»
3. Click in the popup's button «E agora?»; Than close the popup;
4. Click again in «lalala»; The link isn't working now;

Actual Results:  
The link isn't working; In the console javascript an error is reported:

Erro: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMJSWindow.open]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame :: <unknown filename> :: onclick ::
line 0"  data: no]


Expected Results:  
link should work again

...

Comment 1

12 years ago
works for me in winxp firefox 1.0.7 and 1.5 from today. DX, 1.0.6 is insecure
and I _think_ we might have fixed some api regressions in 1.0.7. Can you update
to 1.0.7 or try with a recent 1.5 nightly?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

12 years ago
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.7.10)
Gecko/20050717 Firefox/1.0.6
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.7.10)
Gecko/20050717 Firefox/1.0.6
> 
>  When the source file of the div, where the link 'lalala' is, is reloaded, the
> link gets broken. If the order to reload goes from the main page, there is no
> problem. But when it goes from the popup, there is this prob. In the console
> javascript an error is reported:
> 
> Erro: uncaught exception: [Exception... "Component returned failure code:
> 0x80004005 (NS_ERROR_FAILURE) [nsIDOMJSWindow.open]"  nsresult: "0x80004005
> (NS_ERROR_FAILURE)"  location: "JS frame :: <unknown filename> :: onclick ::
> line 0"  data: no]
> 
> 
>  This only happens in FireFox: In IE and Opera is working fine.
> 
>  Please check the source code of these files:
> 
>  . xhr.html
>  . xhr_data.html
>  . xhr_popup.html
>  . xhr_ap.html
> 
>  (in http://srv2.gimmestock.com/xhr/)
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> 
> 0. Go to «http://srv2.gimmestock.com/xhr/xhr.html»
> 1. Click in 'lalala' to open a popup and see that the link is working; than
> close the popup;
> 2. Click in the main page button «Click»
> 3. Click in the popup's button «E agora?»; Than close the popup;
> 4. Click again in 'lalala'; The link isn't working now;
> 
> Actual Results:  
> The link isn't working; In the console javascript an error is reported:
> 
> Erro: uncaught exception: [Exception... "Component returned failure code:
> 0x80004005 (NS_ERROR_FAILURE) [nsIDOMJSWindow.open]"  nsresult: "0x80004005
> (NS_ERROR_FAILURE)"  location: "JS frame :: <unknown filename> :: onclick ::
> line 0"  data: no]
> 
> 
> Expected Results:  
> link should work again
> 
> ...

(In reply to comment #1)
> works for me in winxp firefox 1.0.7 and 1.5 from today. DX, 1.0.6 is insecure
> and I _think_ we might have fixed some api regressions in 1.0.7. Can you update
> to 1.0.7 or try with a recent 1.5 nightly?

I updated to 1.0.7 (Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.7.12)
Gecko/20050919 Firefox/1.0.7) and still doesn't work. The behavior is the same.
You need to log in before you can comment on or make changes to this bug.