CSS table layout changes on mouse click.

RESOLVED DUPLICATE of bug 311623

Status

()

Core
Layout: Tables
--
trivial
RESOLVED DUPLICATE of bug 311623
13 years ago
13 years ago

People

(Reporter: Wiley Ammons, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

See the example page for demonstration. There is a table that has been put 
together based on a stylesheet, and when a link is clicked, the table layout 
changes. The best example is to click on "items" the link isn't even followed 
and the table shrinks. When you click on a left-hand subheading the link is 
followed, but right before the page changes, you can see that the tables expand.

Reproducible: Always

Steps to Reproduce:
1.Load page
2.Click items
3.Click somewhere in the white space

Actual Results:  
On the item click, the table seems to collapse. Then a whitespace click causes 
the tables to collapse further.

Expected Results:  
Even if the CSS is fishy or written wierd, I would expect a consistant render 
of whatever the stylesheet says. I don't know why there would be dynamic layout 
changes on a page that seems to be configured to be static.
(Reporter)

Comment 1

13 years ago
Created attachment 200235 [details]
The page as rendered on first load
(Reporter)

Comment 2

13 years ago
Created attachment 200236 [details]
Page after first click on "items"
(Reporter)

Updated

13 years ago
Severity: normal → major
(Reporter)

Updated

13 years ago
Severity: major → trivial

Comment 3

13 years ago
as described by reporting user, appallingly written code, probably due to this that the problem occurs

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 311623 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.