software update "Check Now" uses the same accesskey as "Next"

VERIFIED FIXED in mozilla1.8.1

Status

()

Toolkit
Add-ons Manager
P1
normal
VERIFIED FIXED
13 years ago
10 years ago

People

(Reporter: Reuven Gonen, Assigned: mano)

Tracking

({fixed1.8.1, intl, l12y})

Trunk
mozilla1.8.1
fixed1.8.1, intl, l12y
Points:
---
Bug Flags:
blocking1.8rc1 -

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
when Firefox or Thunderbird checks for updates for an extension, the "Check Now"
and "Install Now" buttons use the same accesskey as the wizard "Next" button. in
english it looks ok, since all of these words have "N" in them, but can be a
problem in other locales.
(Reporter)

Comment 1

13 years ago
Created attachment 200290 [details]
screenshot of problem

this screenshot shows the problem on the "he" and "fr" locales

Updated

13 years ago
Flags: blocking1.8rc1?
Keywords: intl
Assignee: nobody → bugs.mano
Keywords: late-l10n
OS: Windows XP → All
Hardware: PC → All
Target Milestone: --- → Firefox1.5rc1

Comment 2

13 years ago
accepting a patch for this would have significant impact for all of the
localizers just days away from 1.5 being done. I'll let Axel comment as to
whether he would approve such a change.
Er, it seems the entities are already there, they're not set right though.
Status: NEW → ASSIGNED
Keywords: late-l10n → l12y
Priority: -- → P1
Created attachment 200310 [details] [diff] [review]
patch

Reuven, does this help?
Attachment #200310 - Flags: review?(mconnor)
(Reporter)

Comment 5

13 years ago
(In reply to comment #2)
> accepting a patch for this would have significant impact for all of the
> localizers just days away from 1.5 being done. I'll let Axel comment as to
> whether he would approve such a change.

This problem seems to be only on the trunk since the wizard 'Next' and 'Back'
access keys(added by Bug 221783) were not added to the branch. in the branch
these buttons simply don't have any accesskeys.
(Reporter)

Comment 6

13 years ago
(In reply to comment #4)
> Created an attachment (id=200310) [edit]
> patch
> 
> Reuven, does this help?

Yes, it works. Thanks!
Comment on attachment 200310 [details] [diff] [review]
patch

this shouldn't hurt l10n since the strings are already there.
Attachment #200310 - Flags: review?(mconnor) → review+

Comment 8

13 years ago
sounds like we don't have this problem on the branch because we lack access keys
on the branch. If that's not correct, let's get this re-nominated. Thanks.
Flags: blocking1.8rc1? → blocking1.8rc1-
(Reporter)

Comment 9

13 years ago
(In reply to comment #8)
> sounds like we don't have this problem on the branch because we lack access keys
> on the branch. If that's not correct, let's get this re-nominated. Thanks.

actually the problem is that the access keys in update.properties are not used,
and this problem is on the branch as well. curently the "don't check" and the
"Cancel" button don't have access keys even in the english version.

see:
http://lxr.mozilla.org/seamonkey/source/toolkit/locales/en-US/chrome/mozapps/extensions/update.properties
Renominating, see comment 9.
Flags: blocking1.8rc1- → blocking1.8rc1?
Component: General → Extension/Theme Manager
QA Contact: general → extension.manager
Checking in update.js;
/cvsroot/mozilla/toolkit/mozapps/extensions/content/update.js,v  <--  update.js
new revision: 1.21; previous revision: 1.20
done
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Reporter)

Updated

13 years ago
Attachment #200310 - Flags: approval1.8rc1?
(Reporter)

Updated

13 years ago
Flags: blocking1.8rc1?
Comment on attachment 200310 [details] [diff] [review]
patch

I only check this in on trunk, Reuven.
Attachment #200310 - Flags: approval1.8rc1?
Flags: blocking1.8rc1?

Comment 14

13 years ago
Mano, can you explain what this patch is doing? If we're currently not using the access keys on the branch, why is this necessary?

Comment 15

13 years ago
Comment on attachment 200310 [details] [diff] [review]
patch

too late to work out adding access keys to our wizard.
Attachment #200310 - Flags: approval1.8rc1? → approval1.8rc1-
(In reply to comment #15)
> (From update of attachment 200310 [details] [diff] [review] [edit])
> too late to work out adding access keys to our wizard.

Asa, this doesn't add accesskeys, it just makes it so that the existing accesskeys are applied correctly.

Updated

13 years ago
Flags: blocking1.8rc1? → blocking1.8rc1-

Comment 17

13 years ago
This isn't a problem on the branch because we don't have access keys enabled anywhere else in wizards on the branch at all. We're not even in agreement that we want access keys in wizards at all. The summary of this bug, "software update "Check Now" uses the same accesskey as "Next"" just doesn't matter since they're not actually exposed. That makes this a request to enable these access specific access keys and we're not going to do that.
Target Milestone: Firefox1.5rc1 → Firefox1.6-
Comment on attachment 200310 [details] [diff] [review]
patch

This is needed on the branch now that bug 221783 was landed on the branch.
Attachment #200310 - Flags: approval-branch-1.8.1?(mconnor)
Comment on attachment 200310 [details] [diff] [review]
patch

This is the right thing to do though we shouldn't need the try catch if the button being set exists and since the same code is setting it it should always exist (e.g. it could cover up other bugs). I'll try to fix that and a few other issues with this wizard in another bug for 2.0
Attachment #200310 - Flags: approval-branch-1.8.1?(mconnor) → approval-branch-1.8.1+
mozilla/toolkit/mozapps/extensions/content/update.js; new revision: 1.17.2.4;
Keywords: fixed1.8.1

Comment 21

13 years ago
Bug is verified fixed in todays 1.8_Branch nightlies.
Status: RESOLVED → VERIFIED

Comment 22

13 years ago
*** Bug 329333 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.