Bugzilla displays attempted HTML links incorrectly

RESOLVED FIXED in Bugzilla 2.16

Status

()

Bugzilla
User Interface
P3
minor
RESOLVED FIXED
19 years ago
6 years ago

People

(Reporter: Jesse Ruderman, Assigned: Christian Reis)

Tracking

unspecified
Bugzilla 2.16
Other
Other

Details

(URL)

(Reporter)

Description

19 years ago
Some bugzilla users attempt to include HTML tags in their posts, for example, 
to link to another bug.  They probably do this because they're used to slashdot-
style linking, and assume that the automatic "Bug #10000" links in other 
people's posts are actually manual links.  The problem isn't that bugzilla 
doesn't allow HTML posts, but that it messes up both the manual link and the 
automatic link (if the anchor text is like "Bug #10000") in this case so that 
other users must type the bug number manually (the horror :)

Bug #31322 shows a few test cases and the results.

Actual results: Bugzilla includes the > in the href and the anchor as part of 
the URL.

Expected results: Link URL is underlined correctly (so it's clickable) but all 
tags are still shown as typed (so pasted html isn't destroyed).  Anchors that 
are bug numbers are also linked to the bug number they refer to.


Related:
Bug #31323, bugzilla should warn users not to use html tags to format messages
Bug #17452, RFE to allow bugzilla comments to be in html format (which probably 
won't be done)
(Reporter)

Comment 1

19 years ago
*** Bug 31322 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
At least, correctly delimited URLs are recognized correctly now (IIRC, they
wasn't a month ago): <http://www.mozilla.org>. Tnx terry!

See RFC2396, for which chars are allowed in URIs. "<> (double quote and angle
brackets) are never allowed. 

Proposed fix:
There's no perl/XPCOM-gateway, is there? :-)
Otherwise stop at the first of the above mentioned chars in all cases.

Comment 3

19 years ago
OK, fixed.  URLs will now never contain ", <, or >.  Bug #31322 now displays
much nicer.

(And no, I did not make any other recent changes to improve "correctly delimited
URLs".)
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 4

19 years ago
Wow, fast and good fix.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 5

18 years ago
Terry, can you make it also hyperlink things like 
<URL:resource:/res/samples/test0.html>?
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 6

18 years ago
David, did you try to add such a link to a webpage and open that link? I did try
it, but I don't think, it will work, because anonymous content doesn't have
access to local resources, IIRC.

Comment 7

18 years ago
I did *not* try it

webpage = html page on a http server
(Reporter)

Comment 8

18 years ago
You're right about that, but I'd still like to see the feature added to 
bugzilla because there are some links that should work, such as finger: links 
(see the first line of comments in bug 33132, and the url of bug 29952).

By the way, you can open those links by right-clicking and selecting "open in 
new window".  Just filed that as bug 35273.

Comment 9

18 years ago
tara@tequilarista.org is the new owner of Bugzilla and Bonsai.  (For details,
see my posting in netscape.public.mozilla.webtools,
news://news.mozilla.org/38F5D90D.F40E8C1A%40geocast.com .)
Assignee: terry → tara
Status: REOPENED → NEW
This bug has not been touched for more than nine months. In most cases, that 
means it has "slipped through the net". Please could the owner take a moment to 
add a comment to the bug with current status, and/or close it.

Thank you :-)

Gerv
Target Milestone: --- → Bugzilla 2.16
-> Bugzilla product, User Interface component, reassigning.
Assignee: tara → myk
Component: Bugzilla → User Interface
Product: Webtools → Bugzilla
Version: other → unspecified
(Assignee)

Comment 12

17 years ago
Uhm, is this solved or not? Could somebody please summarize what is to be done
here so I can go and do it?
Assignee: myk → kiko
Jesse, Ben, you guys were the ones commenting after it was supposedly fixed
before.  What else still needs to be done?  It's hard to tell from the comments.

Comment 14

17 years ago
Bug is fixed. It has been reopened by Jesse in April 2000 to add more URL
schemes, but that is arguable not not exactly topic of this bug. Please open a
new one for that. Marking FIXED again.
Status: NEW → RESOLVED
Last Resolved: 19 years ago17 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.