Closed Bug 313258 Opened 18 years ago Closed 18 years ago

Error when clicking Check for Updates (only when there are updates available)

Categories

(Toolkit :: Application Update, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: ria.klaassen, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051020 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051020 Firefox/1.5

I see this error appear in Firefox and Thunderbird:

Error: [Exception... "'Failure' when calling method:
[nsIWritablePropertyBag::getProperty]"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://mozapps/content/update/updates.js :: anonymous :: line 614"  data: no]
Source File: chrome://mozapps/content/update/updates.js
Line: 614

It is an old error; I see it also in a build of 31 Aug 2005 and maybe earlier.
Only with javascript.options.showInConsole to true.
Between 4 Oct and 18 Oct there was no update for a newly downloaded build so
there was also no error.


Reproducible: Always

Steps to Reproduce:
1. Start Firefox or Thunderbird
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2005-10-19-06-mozilla1.8/
2. Click Help > Check for Updates.
3. At the moment that the message appears that there are updates available, the
error appears.


Actual Results:  
Succesful update, only with an error.
This is not a bug, but thanks for reporting it in any case :)

The exception is fired because the updater tries to find a license page to 
display to the user. If one is found then it is displayed. If no license page 
is sent from the server then an exception is thrown and the updater continues 
gracefully.

Resolving INVALID.
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → INVALID
(In reply to comment #2)
> http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/toolkit/mozapps/update/content/updates.js&rev=MOZILLA_1_8_BRANCH#618
> is wrapped in a try{}catch(){}, why is it displaying an error in the console?


Still getting this in recent trunk builds, I reported it in 333245 thinking it was the reason for my updates failing.
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.