Latest Thunderbird trunk build dies on a second start after installation.

RESOLVED DUPLICATE of bug 311332

Status

--
critical
RESOLVED DUPLICATE of bug 311332
13 years ago
12 years ago

People

(Reporter: fredbezies, Assigned: mscott)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051020 SeaMonkey/1.1a
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20051020 SeaMonkey/1.1a

Problem very simple to reproduce. Build thunderbird using latest CVS sources
from today.

Launch it one time, then close it. No problem.

Try to launch again => crash on start.

Recent regression, was not happening yesterday.



Reproducible: Always

Steps to Reproduce:
1.See details



Actual Results:  
Thunderbird crash on 2nd start

Expected Results:  
Thunderbird shows its UI and let me use it.



Could it be related to JS fast loading patches recently added ? I noticed if I
kick out compreg.dat, Thunderbird is launching again.

I will install a talkback enabled build to send a tb to help ;)
(Reporter)

Comment 1

13 years ago
Part of Apple Report, don't know if it will help ?!

"Date/Time:      2005-10-21 15:43:19.904 +0200
OS Version:     10.4.2 (Build 8C46)
Report Version: 3

Command: thunderbird-bin
Path:    /Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin
Parent:  WindowServer [85]

Version: 1.6a1 (1.6a1)

PID:    17404
Thread: 0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0   org.mozilla.thunderbird 	0x002902f8 PresShell::Destroy() + 568
1   org.mozilla.thunderbird 	0x002d0fdc DocumentViewerImpl::Destroy() + 872
2   org.mozilla.thunderbird 	0x007e78ac nsDocShell::Destroy() + 472
3   org.mozilla.thunderbird 	0x0086a530 nsXULWindow::Destroy() + 356
4   org.mozilla.thunderbird 	0x00540fe0 nsWebShellWindow::Destroy() + 280
5   org.mozilla.thunderbird 	0x0006dad8 nsAppShellService::Observe(nsISupports*,
char const*, unsigned short const*) + 64
6   libxpcom_core.dylib     	0x1000f770
nsObserverService::NotifyObservers(nsISupports*, char const*, unsigned short
const*) + 432
7   libxpcom_core.dylib     	0x100078d8 NS_ShutdownXPCOM_P + 164
8   org.mozilla.thunderbird 	0x000090a0 ScopedXPCOMStartup::~ScopedXPCOMStartup
[unified]() + 60
9   org.mozilla.thunderbird 	0x0000d330 XRE_main + 3836
10  org.mozilla.thunderbird 	0x00008578 start + 444
11  org.mozilla.thunderbird 	0x000083ec start + 48"
(Reporter)

Comment 2

13 years ago
Talkback ID : TB10930207Q
(Reporter)

Comment 3

13 years ago
Try again with a younger nightly build, made on 21st october - 3:32pm
mozilla.org time, grabbed with http://ftp.mozilla.org/

MacOS-X only bug ? I will add corrupted compreg.dat in order to help.

Another talkback ID : TB10958093W
Flags: blocking1.9a1?
(Reporter)

Comment 4

13 years ago
Created attachment 200424 [details]
zipped  corrupted compreg.dat

Here is the zipped compreg.dat. If I delete it, Thunderbird is launching
without problem.
(Reporter)

Comment 5

13 years ago
Still crashing, using an homemade build, using source code up-to-date at
yesterday, 10:00pm mozilla.org.

Apple report log :

"Date/Time:      2005-10-22 12:00:06.761 +0200
OS Version:     10.4.2 (Build 8C46)
Report Version: 3

Command: thunderbird-bin
Path:    /Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin
Parent:  WindowServer [59]

Version: 1.6a1 (1.6a1)

PID:    20145
Thread: 0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0   org.mozilla.thunderbird 	0x00290370 PresShell::Destroy() + 568
1   org.mozilla.thunderbird 	0x002d1054 DocumentViewerImpl::Destroy() + 872
2   org.mozilla.thunderbird 	0x007e7340 nsDocShell::Destroy() + 472
3   org.mozilla.thunderbird 	0x00869fc4 nsXULWindow::Destroy() + 356
4   org.mozilla.thunderbird 	0x005406a8 nsWebShellWindow::Destroy() + 280
5   org.mozilla.thunderbird 	0x0006db60 nsAppShellService::Observe(nsISupports*,
char const*, unsigned short const*) + 64
6   libxpcom_core.dylib     	0x1000f770
nsObserverService::NotifyObservers(nsISupports*, char const*, unsigned short
const*) + 432
7   libxpcom_core.dylib     	0x100078d8 NS_ShutdownXPCOM_P + 164
8   org.mozilla.thunderbird 	0x000090a0 ScopedXPCOMStartup::~ScopedXPCOMStartup
[unified]() + 60
9   org.mozilla.thunderbird 	0x0000d330 XRE_main + 3836
10  org.mozilla.thunderbird 	0x00008578 start + 444
11  org.mozilla.thunderbird 	0x000083ec start + 48"

Crashs started on 20 october. What bug could be guilty here ? Fast JS loading ?
Another one ?!

Another one ?
Keywords: crash
(Reporter)

Updated

13 years ago
Version: unspecified → Trunk
(Reporter)

Comment 6

13 years ago
Working : trunk build 2005-10-20-06
Broken : trunk build 2005-10-21-06

So bugs which could be guilty ; I search in mozilla/mail because SM is working.

- bug 306026
- bug 300968 
- bug 285136
- bug 312937

Is there anyway to find a smaller frame ?
(Reporter)

Comment 7

13 years ago
Looks like bug 279839 is guilty here.

See bug 313268, comment #8 :

"------- Comment #8 From Andrew Schultz 2005-10-23 01:49 PDT [reply] -------
I see this bug with a pristine profile on linux.  I can make the bug go away
temporarily by deleting XUL.mfasl /and/ compreg.dat (deleting one or the other
doesn't help).  The next time I start up, I get this bug again."

Comment 8

13 years ago
Blocking the fastload bug, as that is reported to be the cause of this bug.
Blocks: 279839
This is basically bug 311332 -- all bug 279839 did was cause reregistration.

*** This bug has been marked as a duplicate of 311332 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Flags: blocking1.9a1?
You need to log in before you can comment on or make changes to this bug.