Windows Update shows 1.0+ as the available update

VERIFIED DUPLICATE of bug 305261

Status

()

Toolkit
Application Update
VERIFIED DUPLICATE of bug 305261
12 years ago
10 years ago

People

(Reporter: tracy, Unassigned)

Tracking

({regression})

1.8.0 Branch
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Seen on windows Update from 1020 -> 1021

-Install 1020 build
-Help | Check for Updates

Tested results:
an update is found. It says it is for Firefox 1.0+. Also the about this update
link goes to the Firefox 1.0 page.  However, upon completion of the update
process I get : Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5)
Gecko/20051021 Firefox/1.5

Expcected results: The available update should be Firefox 1.5 and the about link
should go to the Firefox 1.5 (beta2) page.

This had been showing as Firefox 1.4.1+. Also Linux this morning did the correct
expected behavior.
Saw the same thing this morning. The update from the 10-20 branch build to
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b5) Gecko/20051021
Firefox/1.5 showed up as "Firefox 1.0+" and was a full download instead of
incremental.
Is this different from bug 305261 comment #4 ? I checked update.xml for the the
2005102005 win32 branch nightly, and it offers 1.5 at the time of posting.
(In reply to comment #3)
https://aus2.mozilla.org/update/1/firefox/1.5/2005102005/x86-msvc/en-US/nightly/update.xml
> is empty for me.

As it should be, since I left out the winnt_. Oops.
(Reporter)

Comment 5

12 years ago
yes, that's very possible as I checked for updates not long after I was notified
that the build for 1021 this morning was complete. Testing that theory now......
Yep. I uninstalled 1021 used installer to install 1020 then Checked for updates.
 it now shows Firefox 1.5 as the available update.
 

*** This bug has been marked as a duplicate of 305261 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

12 years ago
although there is a difference from bug 305261 comment 4.  That bug says it's
looking for Deer Park 1.0+.  This bug it is showing as Firefox 1.0+.  It's
probably the same timing issue of checking for updates before the partial is
available.
The branding has changed in the meantime.
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.