location bar hash doesn't update after being manually set

RESOLVED DUPLICATE of bug 302575

Status

()

--
minor
RESOLVED DUPLICATE of bug 302575
13 years ago
13 years ago

People

(Reporter: birnamdesigns, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8b5) Gecko/20051006 Firefox/1.4.1

After a hash is manually added to a URL, or a URL is updated in the Location
Bar, clicking on anchor links within the page or programmatically moving the
location to another anchor in the same page will not cause the Location Bar to
update itself to show the new hash. The manually updated URL remains until a
complete page load takes place -- either by visiting another page or by
refreshing the current page.

If the page is then bookmarked, the correct URL is saved with the bookmark, even
though it is not the same URL as shown in the Location Bar.

Reproducible: Always

Steps to Reproduce:
1. Visit http://rapidref.birnamdesigns.com/test4.html
2. Click on any of the anchor links on the top line.
3. Manually update the hash in the URL in the Location Bar to "#0", so that the
new URL is http://rapidref.birnamdesigns.com/test4.html#0.
4. Click on any of the anchor links on the top line.

Actual Results:  
After step 3, the hash value remains "#0" regardless of the actions of
subsequent anchor links. The page successfully scrolls to the corresponding
anchor, and a bookmark for that anchor can be created, but the Location Bar will
remain unchanged.

Expected Results:  
After step 3, the hash value in the Location Bar should continue to reflect the
hashes referenced in the anchor links.

In addition to the Firefox 1.5 Beta2, I have tested this (with the same results)
in Firefox 1.0.7.

This bug also involves the problems reported in Bug 204569, where the location
icon is disabled and undraggable after the hash manually updated. The
work-around for both bugs is to refresh the page. These bugs may both be
symptoms of the same problem.

*** This bug has been marked as a duplicate of 302575 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.