Bad number count when download more than 2.2 GB and transfer rate is great than 2000 KB/sec

VERIFIED DUPLICATE of bug 228968

Status

()

Toolkit
Downloads API
--
trivial
VERIFIED DUPLICATE of bug 228968
13 years ago
10 years ago

People

(Reporter: crk01, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.2; es-ES; rv:1.7.8) Gecko/20050511 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; es-ES; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

I tried to download fedora core 4 ( DVD ISO 2.7 GBS ) with a fast connection (
up to 100 MBPS, but in this case, 18 MBPS more or less ), when it passed about
2.2 GBS the numbers turn in negative, also the number indicating the transfer
rate. Anyway, the file was right downloaded.

Reproducible: Didn't try

Steps to Reproduce:
1. Search for a fast server to containd Fedora Core ISO
2. Download it with a connection faster than 18 mbps
3. Just see the download manager, and after 2.2 GBS of file downloaded, it turns
all negative numbers ( maybe the variable is short data type ? )

Actual Results:  
The download manager shows all ratings negative.

Expected Results:  
Show normal ratings, right values maybe

no crashes, only this little bug ;)

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 228968 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.